summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20180918.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 822a9b861bfd..bf974835212f 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -3,3 +3,4 @@ DIST crossdev-20180410.tar.xz 26716 BLAKE2B 67f47052af4299028470613900e7f1b91fd2
DIST crossdev-20180508.tar.xz 26728 BLAKE2B ab92cac544ee787ca91c794191c51faeab99e88bc2fc695c5e913e4137cc941457f5b27bf22f3b6a7991fa46ebdc2e5b4238a01425c5021fa9fc05ca23c51f49 SHA512 a96afeeb03747ce67a39b53b925361d07117b49316b5c657413125413d006de25249b0d3d1804c8a946c288c80beb42aa7c32362b57ac81399d26a67ceccfe04
DIST crossdev-20180731.tar.xz 26808 BLAKE2B eea12e6405546ca5a8409a853afdcbb25f3f2a7336c428b7c6a5d38b29d772989da7c0a59ce282ee925a9126e396bead17798a25bff1b5019a28ba0ef3bc55fc SHA512 245144b57242b7ae1bca65f457bfb60ec4fe1a4cb5f332dc5ac42d14740dda49e7e5266b10e60bebc84be7fabbac827335fcbc8e0dd74e24f423ddfef33edb7e
DIST crossdev-20180818.tar.xz 26904 BLAKE2B 8fce23db9a00429ec8f8487a72cd5724200336bbd1d50ef62d1170cdd2ccb2b3255ba47c516b89f0394fd7e7c935842269eddeddbc308ffdd1194edd7cc916cd SHA512 11ecd46026c1ec673fc18e86d3cc8570341288b2cf4c4a54aa62d3afddb2ad3d3005a30f2b5b35264af89511975b532cb6014009d0f5ec0b18c0256f49196cb5
+DIST crossdev-20180918.tar.xz 26984 BLAKE2B 67cbddfc1ee2a4e6b3cb443b2cb8ac9468067356b007306db01081ee5bb3335548d4a80ecd604510cf806d68190be2b67e73d0a3f25968a7ebc9eb478fdaac73 SHA512 daeb864a88de6a64ab72b7dd3024106b8afa1e6de0b143042466435d4df2b7da1e1a6b314d3f2c2b01fc273b722871352321054d1fc5158d6b7bbabc01ba327c
diff --git a/sys-devel/crossdev/crossdev-20180918.ebuild b/sys-devel/crossdev/crossdev-20180918.ebuild
new file mode 100644
index 000000000000..d1adb4564b57
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20180918.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/portage-2.1
+ sys-apps/portage-mgorny
+ )
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}