summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/roundcube/Manifest2
-rw-r--r--mail-client/roundcube/roundcube-1.1.4.ebuild75
-rw-r--r--mail-client/roundcube/roundcube-1.2_beta.ebuild76
3 files changed, 0 insertions, 153 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 80efe6649e21..f99a4d05a1e3 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,4 +1,2 @@
-DIST roundcubemail-1.1.4.tar.gz 3209549 SHA256 539a11ed38838b221f8139b193d9762638f155c7b0ea9391315865896be16852 SHA512 18c2422d65292cd13bc4ce592e8490cc0a9d3e9551ac4d188db93eb989525af7ccf519642dd2e68a7380ab0d0d4ad4f999af2b7e99da75d88274743949b42f8a WHIRLPOOL c3e310ddb4dc50b46ff28566d030865029364f69db5a3f39be0d37f165c83486a979b4d3ab7d42835baa7ea9506df8947381612403355a628864ecbde1238d02
-DIST roundcubemail-1.2-beta.tar.gz 3421215 SHA256 b7ab853c0a6e52641c851624c4405ce49643553b76c1f50b02b413cb7954fb25 SHA512 454083d6377a07bd418de5593cafb2cc7c0af474e178e322d07adeaa3473ce140a57e6d0a0ee3f58862091bc559596c98d4fb523ef6b9cee91d38064233aade6 WHIRLPOOL 059cd348397a31a3ebf2a6f58acbf832b0722b2740496ae32b4ef036a963a8199fd4f6e718895512ce1fc996da3af65c583f65faef8b817ba94d99fdfda896d3
DIST roundcubemail-1.2.0.tar.gz 3453543 SHA256 e3b89c2772c2c5990da9bca640bc342f486edf356016cf717e6a1083c822b523 SHA512 3d97e816560830437902ede352e8be81cd93050975934b9dfc86ccf745234119bdf63d5f882fa0d1cc445575c1ea05906a87ae81befdb0bbb38002433e4de199 WHIRLPOOL f9b14ffb2520cd7eda798eb96ec8547af9f5b8d288605d5d777d126cddb3f531f53887ae9bd9b16be7bf194e87165ff48722885328c6dab0d1c1a0ee589817c4
DIST roundcubemail-1.2.1.tar.gz 3559023 SHA256 05c0b17c8951db1d220f2f2186e6981545789da0d084a543e28a7d2511db8302 SHA512 7044e4308fff85a23826e4f4652df7e825d713b977696c0d29d563f419cc4e060ef202f824463823c3f348c7e9f4ce8c58d073c960b371c0b9ca3bd77c5453ca WHIRLPOOL 79a47d9bd65578c0177ffa9438d8a9b305e2d725536209955b04fbfc42a31ef3060d351b638dba72ede3fd8b1ef42a9af34493f80ff393a91b8ab31634bf318a
diff --git a/mail-client/roundcube/roundcube-1.1.4.ebuild b/mail-client/roundcube/roundcube-1.1.4.ebuild
deleted file mode 100644
index 0658877dc086..000000000000
--- a/mail-client/roundcube/roundcube-1.1.4.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit webapp
-
-MY_PN=${PN}mail
-MY_P=${MY_PN}-${PV/_/-}
-
-DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
-HOMEPAGE="http://roundcube.net"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-KEYWORDS="amd64 arm ~hppa ppc ~ppc64 ~sparc x86"
-
-IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-# this function only sets DEPEND so we need to include that in RDEPEND
-need_httpd_cgi
-
-RDEPEND="
- ${DEPEND}
- >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
- >=dev-php/PEAR-Auth_SASL-1.0.6
- >=dev-php/PEAR-Mail_Mime-1.8.9
- >=dev-php/PEAR-Mail_mimeDecode-1.5.5
- >=dev-php/PEAR-Net_IDNA2-0.1.1
- >=dev-php/PEAR-Net_SMTP-1.6.2
- virtual/httpd-php
- enigma? ( >=dev-php/PEAR-Crypt_GPG-1.2.0 app-crypt/gnupg )
- ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
- managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
- mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
- spell? ( dev-lang/php[curl,spell] )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- webapp_src_preinst
- dodoc CHANGELOG INSTALL README.md UPGRADING
-
- insinto "${MY_HTDOCSDIR}"
- doins -r [[:lower:]]* SQL
- doins .htaccess
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
- webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- ewarn
- ewarn "When upgrading from <= 0.9, note that the old configuration files"
- ewarn "named main.inc.php and db.inc.php are deprecated and should be"
- ewarn "replaced with one single config.inc.php file."
- ewarn
- ewarn "Run the ./bin/update.sh script to convert those"
- ewarn "or manually merge the files."
- ewarn
- ewarn "The new config.inc.php should only contain options that"
- ewarn "differ from the ones listed in defaults.inc.php."
- ewarn
-}
diff --git a/mail-client/roundcube/roundcube-1.2_beta.ebuild b/mail-client/roundcube/roundcube-1.2_beta.ebuild
deleted file mode 100644
index 2af432350fac..000000000000
--- a/mail-client/roundcube/roundcube-1.2_beta.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit webapp
-
-MY_PN=${PN}mail
-MY_P=${MY_PN}-${PV/_/-}
-
-DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
-HOMEPAGE="http://roundcube.net"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-KEYWORDS=""
-
-IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-# this function only sets DEPEND so we need to include that in RDEPEND
-need_httpd_cgi
-
-RDEPEND="
- ${DEPEND}
- >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
- >=dev-php/PEAR-Auth_SASL-1.0.6
- >=dev-php/PEAR-Mail_Mime-1.8.9
- >=dev-php/PEAR-Mail_mimeDecode-1.5.5
- >=dev-php/PEAR-Net_IDNA2-0.1.1
- >=dev-php/PEAR-Net_SMTP-1.6.2
- virtual/httpd-php
- enigma? ( >=dev-php/PEAR-Crypt_GPG-1.2.0 app-crypt/gnupg )
- ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
- managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
- mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
- spell? ( dev-lang/php[curl,spell] )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- webapp_src_preinst
- dodoc CHANGELOG INSTALL README.md UPGRADING
-
- insinto "${MY_HTDOCSDIR}"
- doins -r [[:lower:]]* SQL
- doins .htaccess
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
- fperms -R 0755 "${MY_HTDOCSDIR}"/bin
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
- webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- if has_version "<mail-client/roundcube-1.0.0"; then
- ewarn "When upgrading from <= 1.0.0, note that the old configuration files"
- ewarn "named main.inc.php and db.inc.php are deprecated and should be"
- ewarn "replaced with one single config.inc.php file."
- ewarn
- ewarn "Run the ./bin/update.sh script to convert those or manually merge the"
- ewarn "files."
- ewarn
- ewarn "The new config.inc.php should only contain options that differ from"
- ewarn "the ones listed in defaults.inc.php."
- fi
-}