summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-engines/box2d/Manifest3
-rw-r--r--games-engines/box2d/box2d-2.1.2.ebuild45
-rw-r--r--games-engines/box2d/box2d-2.2.1.ebuild45
-rw-r--r--games-engines/box2d/box2d-2.3.1.ebuild43
-rw-r--r--games-engines/box2d/metadata.xml11
5 files changed, 147 insertions, 0 deletions
diff --git a/games-engines/box2d/Manifest b/games-engines/box2d/Manifest
new file mode 100644
index 000000000000..26dc21a63d3f
--- /dev/null
+++ b/games-engines/box2d/Manifest
@@ -0,0 +1,3 @@
+DIST Box2D_v2.1.2.zip 3100922 BLAKE2B 1f2d2b201517ef2adb1b1a2c1f62f94b2f7cde6f857935dba11544b931481a2b87e036269f34571b99f5272b9dd985dcf463d153b628c54163166e2ae77d95d5 SHA512 cc50be6db8d02a4ddbb61208f67b05c264e24ab96885debc708b1b284957f18193b6a57d84d378cb0ba33ab3fc9a0f5c534b8ca9f8982e7e0fe656115cb5a82f
+DIST Box2D_v2.2.1.zip 3637276 BLAKE2B 844b589b43b916e20cb594ba160c4a025b2fb98bacb7c856884ec728c7b67f44ed86151df0b005ce1c813d74c8c55ce93e5060b4b9387662870cdcda9cdea76e SHA512 3d0d4eb06d9e2c425ffafb26839032cae897a4a82f27356ccad2fc764a02c3ca6dd53b24c51196291f5492f795356fb03575f8c75e599467577ba19165ccdcb4
+DIST box2d-2.3.1.tar.gz 1553222 BLAKE2B e21eafb9d807c5f241486c875bd8ee350c3e44601801b98d9ee35e2343244f5c72998cbc1e9f687d3a72033a76361a1ff7dd3bacad50f21212fca3618e887bb6 SHA512 22e31005644ae1f5a947149dee832286b0d5a96648a0e9766c32a9a047ae839b4354403eaf7040895074cf3bd33bb298e65053cf1b5b67a6a23fbf3fd5777dd5
diff --git a/games-engines/box2d/box2d-2.1.2.ebuild b/games-engines/box2d/box2d-2.1.2.ebuild
new file mode 100644
index 000000000000..953853c49214
--- /dev/null
+++ b/games-engines/box2d/box2d-2.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib
+
+MY_PN="Box2D"
+DESCRIPTION="A C++ engine for simulating rigid bodies in 2D games"
+HOMEPAGE="https://box2d.org/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${MY_PN}_v${PV}.zip"
+LICENSE="ZLIB"
+SLOT="$(ver_cut 1-2).0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}_v${PV}/${MY_PN}"
+
+src_prepare() {
+ # This version supports CMake but upstream has dropped it since this
+ # release. They now use Premake but this Meson file is actually
+ # simpler! Installation is manual but that's true for Premake too.
+ cat > meson.build <<EOF || die
+project('${MY_PN}', 'cpp')
+shared_library(
+ '${MY_PN}',
+ $(find ${MY_PN} -name "*.cpp" -printf "'%p', ")
+ soversion: '${SLOT}', install : true
+)
+EOF
+
+ default
+}
+
+src_install() {
+ dodoc Readme.txt
+ dolib.so "${BUILD_DIR}"/lib${MY_PN}$(get_libname ${SLOT})
+
+ local FILE
+ for FILE in $(find ${MY_PN} -name *.h); do
+ insinto "/usr/include/${MY_PN}-${SLOT}/${FILE%/*}"
+ doins "${FILE}"
+ done
+}
diff --git a/games-engines/box2d/box2d-2.2.1.ebuild b/games-engines/box2d/box2d-2.2.1.ebuild
new file mode 100644
index 000000000000..5663da2c4f6e
--- /dev/null
+++ b/games-engines/box2d/box2d-2.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib
+
+MY_PN="Box2D"
+DESCRIPTION="A C++ engine for simulating rigid bodies in 2D games"
+HOMEPAGE="https://box2d.org/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${MY_PN}_v${PV}.zip"
+LICENSE="ZLIB"
+SLOT="$(ver_cut 1-2).0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}_v${PV}"
+
+src_prepare() {
+ # This version supports CMake but upstream has dropped it since this
+ # release. They now use Premake but this Meson file is actually
+ # simpler! Installation is manual but that's true for Premake too.
+ cat > meson.build <<EOF || die
+project('${MY_PN}', 'cpp')
+shared_library(
+ '${MY_PN}',
+ $(find ${MY_PN} -name "*.cpp" -printf "'%p', ")
+ soversion: '${SLOT}', install : true
+)
+EOF
+
+ default
+}
+
+src_install() {
+ dodoc Readme.txt
+ dolib.so "${BUILD_DIR}"/lib${MY_PN}$(get_libname ${SLOT})
+
+ local FILE
+ for FILE in $(find ${MY_PN} -name *.h); do
+ insinto "/usr/include/${MY_PN}-${SLOT}/${FILE%/*}"
+ doins "${FILE}"
+ done
+}
diff --git a/games-engines/box2d/box2d-2.3.1.ebuild b/games-engines/box2d/box2d-2.3.1.ebuild
new file mode 100644
index 000000000000..9a083d4ffb02
--- /dev/null
+++ b/games-engines/box2d/box2d-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib
+
+MY_PN="Box2D"
+DESCRIPTION="A C++ engine for simulating rigid bodies in 2D games"
+HOMEPAGE="https://box2d.org/"
+SRC_URI="https://github.com/erincatto/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="$(ver_cut 1-2).0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${MY_PN}"
+
+src_prepare() {
+ # This version supports CMake but upstream has dropped it since this
+ # release. They now use Premake but this Meson file is actually
+ # simpler! Installation is manual but that's true for Premake too.
+ cat > meson.build <<EOF || die
+project('${MY_PN}', 'cpp')
+shared_library(
+ '${MY_PN}',
+ $(find ${MY_PN} -name "*.cpp" -printf "'%p', ")
+ soversion: '${SLOT}', install : true
+)
+EOF
+
+ default
+}
+
+src_install() {
+ dodoc {Changes,Readme}.txt
+ dolib.so "${BUILD_DIR}"/lib${MY_PN}$(get_libname ${SLOT})
+
+ local FILE
+ for FILE in $(find ${MY_PN} -name *.h); do
+ insinto "/usr/include/${MY_PN}-${SLOT}/${FILE%/*}"
+ doins "${FILE}"
+ done
+}
diff --git a/games-engines/box2d/metadata.xml b/games-engines/box2d/metadata.xml
new file mode 100644
index 000000000000..f73e6cf85872
--- /dev/null
+++ b/games-engines/box2d/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">erincatto/Box2D</remote-id>
+ </upstream>
+</pkgmetadata>