summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-14.1.9025.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index d194cce64567..1a91c671d15b 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -6,3 +6,5 @@ DIST teamviewer_14.0.14470_amd64.tar.xz 19458912 BLAKE2B ae106af9126719d92d69501
DIST teamviewer_14.0.14470_i386.tar.xz 19473776 BLAKE2B a96ed757c6af5e07d4b958d2034c94bdd04625e0ae68c6dba94eebd1f1416f33e339a8766161bfa412ce90119a70cefbded995d66656ac11c0b08869639ba15b SHA512 6c867e32f26df3675bee80e3dfb2aa5868f3bf4717ce07deabc7495d2797018051dde42080eea6e3c0a919e20f5517d621e075c7d7f75cabec4b6feeae5fa74d
DIST teamviewer_14.1.3399_amd64.tar.xz 11311600 BLAKE2B 082b23322b4a24add2f7a1235810a3fb3cfd6572ccfe2a54942bd93902d3adc170a175d32653375c406de7a54949fd0904dfae8b8cf98da58ef492ac63d0e576 SHA512 9417fca34d2b4b3e53d173ed31f85ca6d3f2488dceb7bf2321082631b425d7c3404549ff4bfe615e6f8f82354df5c43ab61e8cd4ec99ae9c42b28807ea0db365
DIST teamviewer_14.1.3399_i386.tar.xz 11305576 BLAKE2B 1a40cd6dd5e1554b44d210fb0ca78a3570185e046b12eba52d0e089cd317ab6c8828f774d6b786ab7232ad663785bd9fb2e9137eb0ea7364347ea5513ab5e6ef SHA512 0fef5c5794ea06d9a729cd5be0b2e7c28add1fca9bbf9e77ca69fe569a08fc1efb6dc007040d8a8d3608061469dc2e2d364584130316d58e2d8195b2389deb0f
+DIST teamviewer_14.1.9025_amd64.tar.xz 11357456 BLAKE2B d3401b4465341533e0e3e7d57515566b1833689cb55d3d2b2b4ca95ed706ebd5609698b128033737dc1532e10fd15837241f11e327d3345ef266b90d2837075c SHA512 2a6fcfd3bb74a9e0f97bd94cf92ba5c8500c17436887e186c6b65d1c02b984799a41003e0cb58af503ece6c9c4f8205c907ba179b491efd3b765ef34b1ec9f76
+DIST teamviewer_14.1.9025_i386.tar.xz 11357824 BLAKE2B 6eb496549e39a1f66a5e14af3d69f8f11dda1549e4af51d354fa8cdfd027dec58240dc6ddacbaf0b1c0ccecf918873d9307f6d75a09abf180a1be5aff65f2613 SHA512 b5ff7e417ffa59725656611348dd717141fa010460f2d872ef555471f22af24d7dde02b0356eece69eb2a7e8fb0d94024646b74e9c8d5c00577eeda1e8c9a713
diff --git a/net-misc/teamviewer/teamviewer-14.1.9025.ebuild b/net-misc/teamviewer/teamviewer-14.1.9025.ebuild
new file mode 100644
index 000000000000..2887c5d78191
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-14.1.9025.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="${PV/\.*}"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+"
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+ -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_PN}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd14.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/${MY_PN}
+ dosym ../../etc/${MY_PN} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_PN}
+ dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}