summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/pcmanfm-qt/pcmanfm-qt-0.13.0-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/pcmanfm-qt/pcmanfm-qt-0.13.0-r1.ebuild b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..3c0eff8e3ba3
--- /dev/null
+++ b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.13.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver xdg-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Fast lightweight tabbed filemanager (Qt port)"
+HOMEPAGE="https://lxqt.org/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/libfm-1.2.0:=
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+ x11-libs/libxcb:=
+ x11-misc/xdg-utils
+ virtual/eject
+ virtual/freedesktop-icon-theme
+ !lxqt-base/lxqt-common
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.5.0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}