summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/ripgrep/Manifest1
-rw-r--r--sys-apps/ripgrep/ripgrep-0.5.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
index 65ed6c4cbc7a..fa7627d5ff56 100644
--- a/sys-apps/ripgrep/Manifest
+++ b/sys-apps/ripgrep/Manifest
@@ -1,2 +1,3 @@
DIST ripgrep-0.3.2.tar.xz 36002204 SHA256 a45c2af4efac72c12b8fe9eae05ca5f84f06f7387f94e6dcc614d4334955e44a SHA512 49463d442f1425b591fb17fc33ef8e1a34f368ce7d5862f375094936afc5140f09cece13fa193e9848d85c810e67503f648ec04d19298e23517f1443b7afc426 WHIRLPOOL 6972b47d8b34f76cd2b4ecf0787e8cede8454676dbc1a9cf889bba1d4a877a03eda844b705eea11a42def712c0253a6de7d602a4f0c52d888c36cbd0a9668ef4
DIST ripgrep-0.4.0.tar.xz 39090216 SHA256 4ebf332e904af6a49195457dc235d8f543a15e130862bf604052a44792406c04 SHA512 a39986b7d08b9661d0d2a3c352a885eeecc0e0dba5fc130ce003f536e1f4638051ba95ab28f0502b778467f3a9a5dc02dd94f38d243b08cb547a8973665e89dd WHIRLPOOL 9b41f8e47cca59ed878283e0fc15211eb745223a54caafc5a9c396a617bbfa9f46783d1cc1ed7d58085de19b0bf3d789e2ec3dbf02216aa0f0f0a44d1042ae1d
+DIST ripgrep-0.5.0.tar.xz 45199048 SHA256 1e13a0a81ddc82fa59bfbfc08215ddbf17bd73bebfb4c0f419ea035c7c0ded17 SHA512 773f991a18ecaa9b97d6b7a1331368c309bdd8c68c52cc9b6360702adedae9bfa4849ec79fd8012923e734156e334f9d6d0dd11be8f01d9e01641d22fe506342 WHIRLPOOL 11938d10158e345ba2011587e130adb8d1f0865b11fad2082ac91ce53aedd63d08555316bda3bb2345ca062bf72638c60cb3d672c126aa1b3fd08664c2fb6a0e
diff --git a/sys-apps/ripgrep/ripgrep-0.5.0.ebuild b/sys-apps/ripgrep/ripgrep-0.5.0.ebuild
new file mode 100644
index 000000000000..8445e52f2c6f
--- /dev/null
+++ b/sys-apps/ripgrep/ripgrep-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="a command line search tool that combines usability with raw speed"
+HOMEPAGE="https://github.com/BurntSushi/ripgrep"
+#SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# custom tarball bundling all deps and index, otherwise cargo fetches from the network
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-util/cargo
+ >=dev-lang/rust-1.11
+"
+
+src_prepare() {
+ default
+
+ # move cache dir where cargo expects it
+ mv .cargo "${HOME}" || die
+}
+
+src_compile() {
+ cargo build --release --verbose || die
+}
+
+src_test() {
+ cargo test || die "tests failed"
+}
+
+src_install() {
+ dobin target/release/rg
+ doman doc/rg.1
+ dodoc CHANGELOG.md README.md
+}