summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-5.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index c36c4a617da4..65472af2543f 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-5.0.0.tar.gz 18532 BLAKE2B f3d59b7d7d2974564b0c7cf25d5bf8716610aa09dd134e37289648e71c4dd6989bfecfafd258da01875de0560cef31fcb8ee0ec85e16d642ff56d10915da6132 SHA512 e95fff8c460329c8369f8f819a95341ec4e1641d2ecc88251c9681ac5e9678eded0f320aa1bff98a980fc552cb214ea3f40c249ea25b54d8fbe34849fffff7b6
+DIST tempora-5.0.1.tar.gz 18456 BLAKE2B b21d60dc8fa5ff9701bbdf66cc9f657c9e4bc779a4a564ea788b201034f818a688c53bcd94f315ef4650b62cce1866fad4a196e2ab724e89670bbc36e9ea15ac SHA512 941b1a231bfae6cf2321325ada785806578643dc9ae215116393623f780de7a409f918c215aae353013bd89c6866ab870ac61470af09f281af0953ce6e20ea3b
diff --git a/dev-python/tempora/tempora-5.0.1.ebuild b/dev-python/tempora/tempora-5.0.1.ebuild
new file mode 100644
index 000000000000..79fbff472b4e
--- /dev/null
+++ b/dev-python/tempora/tempora-5.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"