summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gvfs/Manifest1
-rw-r--r--gnome-base/gvfs/files/1.38.3-gvfsdaemon-rpath.patch35
-rw-r--r--gnome-base/gvfs/gvfs-1.38.3.ebuild136
3 files changed, 172 insertions, 0 deletions
diff --git a/gnome-base/gvfs/Manifest b/gnome-base/gvfs/Manifest
index cdb6a298c3c6..54e8010399d5 100644
--- a/gnome-base/gvfs/Manifest
+++ b/gnome-base/gvfs/Manifest
@@ -1,3 +1,4 @@
DIST gvfs-1.32.2-patchset.tar.xz 22152 BLAKE2B 46371e4da9f3259ae1be6e7900aa9c3fa83913cf1f5ac80c485abc6a10bd77667e7fad29a09eb160af39212da31c00ccccbc3e47b4ed79780e254ff78d4b7130 SHA512 d7a17a33b737d8ac679e259055b57f63ef18f783dd7887c726502f8c05cb9339addd8728ee180ed15dc7d067ff45cc1888bc42a8ca45f9734717cfcde53f3e45
DIST gvfs-1.32.2.tar.xz 1820100 BLAKE2B a12209f8d1f1350edfc470bb8181d68172580909764899a20b248e5dca673e5904aef0562f3244336dd8eff66cbae926d4fb2ebcccc30125328e15aeb622b481 SHA512 2fecb7103917f976528a75d317ddb6c9a71c2787cd1bd442c42a40177b74a026e37c9794117f802ebf608091d446ac58eb80d1a618df619180bb3920a98a9457
DIST gvfs-1.38.2.tar.xz 1202808 BLAKE2B 31150c10e042b262a55f4a072496138f47532ec55c2cae564d7c1a7a06b043bf131a91a633757fc02a0a31fc052a6ae64bd25d357cf60efa10b9490c6d1a9d84 SHA512 b6982f2c23cae057aebd00dab52b4f21f8bcef79fc5e97c098d54a9ebf997913f53146bd1760065454198c94a66f1bc1fc5325b08fea10e63a755fad87321488
+DIST gvfs-1.38.3.tar.xz 1202280 BLAKE2B fb4d4f6d0187f4f1bdfdff42f496402c64077958816d1a07d1689b8d477538c11ce26ef5caba1ff8ed16f1188ff5e59d92ce807f4adbf7d9749fe59da6a0e2dc SHA512 4497d04942881e7e7fe6541fc5951bcc03c89305dc975ed1cd0368acf382ac66a532f3b7c781c4dec5662bf71dd6346a93378096c0cbec5f6331d75c85b96175
diff --git a/gnome-base/gvfs/files/1.38.3-gvfsdaemon-rpath.patch b/gnome-base/gvfs/files/1.38.3-gvfsdaemon-rpath.patch
new file mode 100644
index 000000000000..f3fe513d06e1
--- /dev/null
+++ b/gnome-base/gvfs/files/1.38.3-gvfsdaemon-rpath.patch
@@ -0,0 +1,35 @@
+From 57010ebb148b9b14e40140c7a8ce133a72128cf6 Mon Sep 17 00:00:00 2001
+From: Robby Workman <rworkman@slackware.com>
+Date: Thu, 18 Jul 2019 03:38:41 -0500
+Subject: [PATCH] daemon/meson.build: define gvfs_rpath for libgvfsdaemon.so
+
+On Slackware development branch with gvfs-1.40.2, I just noticed this:
+ # ldd /usr/lib64/gvfs/libgvfsdaemon.so | grep "not found"
+ libgvfscommon.so => not found
+
+After some backtracking, it seems that this first occurred in the
+switchover from autotools to meson in the 1.36.x --> 1.38.x bump.
+
+Big thanks to Cogitri in #gnome/irc.gnome.org for the patience and
+assistance with troubleshooting this.
+
+Signed-off-by: Robby Workman <rworkman@slackware.com>
+---
+ daemon/meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/daemon/meson.build b/daemon/meson.build
+index 7f2608bd..0006f35e 100644
+--- a/daemon/meson.build
++++ b/daemon/meson.build
+@@ -121,6 +121,7 @@ libgvfsdaemon = shared_library(
+ dependencies: deps,
+ c_args: cflags,
+ install: true,
++ install_rpath: gvfs_rpath,
+ install_dir: gvfs_pkglibdir
+ )
+
+--
+2.20.1
+
diff --git a/gnome-base/gvfs/gvfs-1.38.3.ebuild b/gnome-base/gvfs/gvfs-1.38.3.ebuild
new file mode 100644
index 000000000000..4daf8b8ab962
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.38.3.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="Virtual filesystem implementation for GIO"
+HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive bluray cdda elogind fuse google gnome-keyring gnome-online-accounts gphoto2 +http ios mtp nfs policykit samba systemd test +udev udisks zeroconf"
+# elogind/systemd only relevant to udisks (in v1.38.1)
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ cdda? ( udev )
+ google? ( gnome-online-accounts )
+ gphoto2? ( udev )
+ mtp? ( udev )
+ udisks? ( udev )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.57.2:2
+ afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ sys-apps/dbus
+ app-crypt/gcr:=
+ policykit? (
+ >=sys-auth/polkit-0.114
+ sys-libs/libcap )
+ http? (
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42.0:2.4 )
+ zeroconf? ( >=net-dns/avahi-0.6 )
+ udev? ( >=virtual/libgudev-147:= )
+ fuse? ( >=sys-fs/fuse-2.8.0:0 )
+ udisks? ( >=sys-fs/udisks-1.97:2 )
+ systemd? ( >=sys-apps/systemd-206:0= )
+ elogind? ( >=sys-auth/elogind-229:0= )
+ ios? (
+ >=app-pda/libimobiledevice-1.2:=
+ >=app-pda/libplist-1:= )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.1:= )
+ gnome-keyring? ( app-crypt/libsecret )
+ bluray? ( media-libs/libbluray:= )
+ mtp? (
+ >=dev-libs/libusb-1.0.21
+ >=media-libs/libmtp-1.1.15 )
+ samba? ( >=net-fs/samba-4[client] )
+ archive? ( app-arch/libarchive:= )
+ cdda? (
+ dev-libs/libcdio:0=
+ >=dev-libs/libcdio-paranoia-0.78.2 )
+ google? ( >=dev-libs/libgdata-0.17.9:=[crypt,gnome-online-accounts] )
+ gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
+ nfs? ( >=net-fs/libnfs-1.9.8 )
+ net-misc/openssh
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+"
+
+PATCHES=(
+ # from gnome-3-30 branch, fixes RPATH of libgvfsdaemon.so
+ "${FILESDIR}"/${PV}-gvfsdaemon-rpath.patch
+)
+
+src_configure() {
+ local enable_logind="false"
+ if use systemd || use elogind; then
+ enable_logind="true"
+ fi
+
+ local enable_gcrypt="false"
+ if use afp; then # currently HAVE_GCRYPT and linkage only used with afp; check it on big bumps (grep for HAVE_GCRYPT and enable_gcrypt); adjust depends if changes
+ enable_gcrypt="true"
+ fi
+
+ local enable_libusb="false"
+ if use mtp; then # currently HAVE_LIBUSB and linkage only used with mtp; check it on big bumps (grep for HAVE_LIBUSB and enable_libusb); adjust depends if changes
+ enable_libusb="true"
+ fi
+
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+ $(meson_use policykit admin)
+ $(meson_use ios afc)
+ $(meson_use afp)
+ $(meson_use archive)
+ $(meson_use cdda)
+ $(meson_use zeroconf dnssd)
+ $(meson_use gnome-online-accounts goa)
+ $(meson_use google)
+ $(meson_use gphoto2)
+ $(meson_use http)
+ $(meson_use mtp)
+ $(meson_use nfs)
+ -Dsftp=true
+ $(meson_use samba smb)
+ $(meson_use udisks udisks2)
+ $(meson_use bluray)
+ $(meson_use fuse)
+ -Dgcr=true
+ -Dgcrypt=${enable_gcrypt}
+ $(meson_use udev gudev)
+ $(meson_use gnome-keyring keyring)
+ -Dlogind=${enable_logind}
+ -Dlibusb=${enable_libusb}
+ -Ddevel_utils=false # wouldn't install any of it as of 1.38.1; some tests need it, but they aren't automated tests in v1.38.1
+ -Dinstalled_tests=false
+ -Dman=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_giomodule_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_giomodule_cache_update
+}