summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/nbclient/nbclient-0.9.0.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/nbclient/nbclient-0.9.0.ebuild b/dev-python/nbclient/nbclient-0.9.0.ebuild
index 9df0f1f9898b..4d0d33c91dd0 100644
--- a/dev-python/nbclient/nbclient-0.9.0.ebuild
+++ b/dev-python/nbclient/nbclient-0.9.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 pypi
@@ -38,17 +38,10 @@ BDEPEND="
)
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
EPYTEST_DESELECT=(
- nbclient/tests/test_client.py::test_many_parallel_notebooks
- 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+ # hangs?
+ 'tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
)
-
-python_test() {
- # The tests run the pydevd debugger, the debugger prints a warning
- # in python3.11 when frozen modules are being used.
- # This warning makes the tests fail, silence it.
- local -x PYDEVD_DISABLE_FILE_VALIDATION=1
- epytest
-}