summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/netbox/Manifest1
-rw-r--r--www-apps/netbox/netbox-2.7.2.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/www-apps/netbox/Manifest b/www-apps/netbox/Manifest
index 7a8e0e741482..acadbe59187b 100644
--- a/www-apps/netbox/Manifest
+++ b/www-apps/netbox/Manifest
@@ -6,3 +6,4 @@ DIST netbox-2.6.5.tar.gz 2408180 BLAKE2B d119a1bf8256e0d6265eda7122a1d436ecb0e8e
DIST netbox-2.6.6.tar.gz 2414895 BLAKE2B b27e1bd5bf810627a4ec563b2eb5dbd7c86bf3d98e52555e511ee16492fd96a6cb7604dce8f5954120ab8b3a48d6acf7878721005bcfd2bd9e3880294dfbcd4d SHA512 9b44442cea1f76cdecb37faee8fe32012b869ff63c1b0bc678d2bb8624851941e9296854a9d85abea24e49a75fd5b31b968e4adbd56e5bc03a1c9f28fc8b846e
DIST netbox-2.6.7.tar.gz 2416096 BLAKE2B 9c9744b60c3999fa7c3336539937cc20eebac67559444a4512cc4d69e8d38babc147254fd1fc49b8515203a8fd4411bc61c4c30aa3313e1ffe0d0e86abd8c9bb SHA512 63ed6a95a1f33ee5dd19dc2e43fc5c6aa09979c6f6856b28060992a8aaee956363caf20c48e72884adb84d260669d828311c0cf0d143fc0e58fed9677baf76db
DIST netbox-2.6.8.tar.gz 2416523 BLAKE2B 1624415302696f47f799f8bd42b827bfdac7866e750ad71cca84a3c095aa39e403036d82257c864f0e4ecc1725087cc1253c73fa26928915e2c53213c3a3852a SHA512 12a094434c66f954cdd356a41123d5e6c2df8ba9aa846731ee439fd0bf330a003ca4b96c8889aef7be2e551c1d518e96c83182168049a76e9cf4ca3104533280
+DIST netbox-2.7.2.tar.gz 4936914 BLAKE2B 905e2667d0637d2edb655efcba1d697eacb097ddd67c8e4586ee2a3ce5a81e4fe98a71f574ae5c732190e03e42fd4cab2f781a30622e79d5e9ea4db7c86de263 SHA512 87753ce955e296d9605e44d5f0df58c14876ca8feda3245dee166fba8a51cbfda7def8da39663570cd0e7c9195cc163d9e877b59027ea1161c7eec33702a3ea4
diff --git a/www-apps/netbox/netbox-2.7.2.ebuild b/www-apps/netbox/netbox-2.7.2.ebuild
new file mode 100644
index 000000000000..f80801767e3f
--- /dev/null
+++ b/www-apps/netbox/netbox-2.7.2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="IP address and data center infrastructure management tool"
+HOMEPAGE="https://github.com/netbox-community/netbox"
+SRC_URI="https://github.com/netbox-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ldap"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+acct-group/netbox
+acct-user/netbox
+ ${PYTHON_DEPS}
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/django-cacheops-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-cors-headers-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/django-debug-toolbar-2.1[${PYTHON_USEDEP}]
+ >=dev-python/django-filter-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/django-mptt-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/django-prometheus-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/django-rq-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/django-tables2-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/django-taggit-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/django-taggit-serializer-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/django-timezone-field-4.0[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-3.10.3[${PYTHON_USEDEP}]
+ >=dev-python/drf-yasg-1.17.0[${PYTHON_USEDEP},validation]
+ >=dev-python/jinja-2.10.3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.6.11[${PYTHON_USEDEP}]
+ <dev-python/markdown-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.19[${PYTHON_USEDEP}]
+ >=dev-python/pillow-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.4[${PYTHON_USEDEP}]
+ >=dev-python/py-gfm-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.9.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.3.11[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ ldap? ( >=dev-python/django-auth-ldap-1.7[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.7-no-pip.patch
+ )
+
+DISABLE_AUTOFORMATTING=YES
+DOC_CONTENTS="
+netbox is installed on your system. However, there are some manual steps
+you need to complete from the installation guide [1].
+
+On Gentoo, the configuration files you need to edit are located in
+/etc/netbox, not /opt/netbox as shown in the installation guide.
+
+If this is a new installation, please follow the installation guide
+other than this difference. Also, if you need ldap, set the appropriate
+use flag when emerging netbox to install the dependency for it.
+
+Once that is done, you should be able to add the netbox service to the
+default runlevel and start it.
+
+If you want to use webhooks, you should also add the netbox-rqworker
+service to the default runlevel and start it.
+
+If this is an upgrade, follow these instructions:
+
+Stop the netbox service. If the netbox-rqworker service is running,
+stop it as well.
+
+Next, run the upgrade script as described in the upgrading guide[2].
+
+Next, check for new configuration options and set them as appropriate
+for your system.
+
+Next, start the netbox service.
+
+Finally, if you are using webhooks, start the netbox-rqworker service.
+
+[1] https://netbox.readthedocs.io/en/stable/installation/
+[2] https://netbox.readthedocs.io/en/stable/installation/upgrading/
+"
+
+src_install() {
+ dodir /opt
+ cp -a ../${P} "${ED}"/opt
+ dosym ${P} /opt/netbox
+dosym ../../etc/netbox/gunicorn_config.py /opt/netbox/gunicorn_config.py
+ dosym ../../../../etc/netbox/configuration.py \
+ /opt/netbox/netbox/netbox/configuration.py
+ dodir /etc/netbox
+ insinto /etc/netbox
+ newins netbox/netbox/configuration.example.py configuration.py
+ doins "${FILESDIR}"/gunicorn_config.py
+ fowners -R netbox:netbox /etc/netbox /opt/${P}
+ fowners -h netbox:netbox /opt/netbox
+ fperms o= /etc/netbox/configuration.py /etc/netbox/gunicorn_config.py
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newinitd "${FILESDIR}"/${PN}-rqworker.initd ${PN}-rqworker
+ keepdir /var/log/netbox
+ fowners -R netbox:netbox /var/log/netbox
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ local r
+ for r in $REPLACING_VERSIONS; do
+ if [[ $r = "2.5.10" ]]; then
+ ewarn "The home directory of the netbox user is now /var/lib/netbox"
+ ewarn "Please adjust your system."
+ fi
+ done
+}