summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libetpan/Manifest1
-rw-r--r--net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch30
-rw-r--r--net-libs/libetpan/libetpan-1.9.3.ebuild77
-rw-r--r--net-libs/libetpan/libetpan-1.9.4.ebuild77
4 files changed, 0 insertions, 185 deletions
diff --git a/net-libs/libetpan/Manifest b/net-libs/libetpan/Manifest
index d37beb8e3f4c..667fb19ac966 100644
--- a/net-libs/libetpan/Manifest
+++ b/net-libs/libetpan/Manifest
@@ -1,2 +1 @@
-DIST libetpan-1.9.3.tar.gz 5000049 BLAKE2B 1664d93b112410a86935438aae5ff40202a9c10675701d40b60edf81e4f8bac45fb1f407e03714a37465c41a22c1b9fcbbc517d76dc47f812e154c932e05e600 SHA512 66e504fbf82445819845a3f1dcb8dc48ad2440993134d43752c754463cee2434a30080718687cd05c579f0da8df6b0f6dfc7572f2882d0dd9dfd327b4ae11fd6
DIST libetpan-1.9.4.tar.gz 5000025 BLAKE2B dd98169134b7448d3dd129814d8011a3fa915b16f4763344230a89d02626b64ddea57495b4c21fd8f651164c36c95ad98ee9db073273b230e6af403b845aa681 SHA512 7b7047d084fb4ce0c91821c2ad78e921d6d009106851afb7f5b068713c84ebe6926f6bf7a7423f263eeebef617511e44f6b65448d892bbc058c447235fd55c0f
diff --git a/net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch b/net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch
deleted file mode 100644
index 9d53f90190b0..000000000000
--- a/net-libs/libetpan/files/libetpan-1.9.3-missing-stddev_h.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-commit da9fd7839c9affea48f74a159a789fbb183b4be1
-Author: maxice8 <30738253+maxice8@users.noreply.github.com>
-Date: Fri Feb 1 01:58:08 2019 -0200
-
- add missing stddef.h include for 'NULL' (#322)
-
- clientid.c: In function 'mailimap_clientid':
- clientid.c:66:38: error: 'NULL' undeclared (first use in this function)
- if (mailimap_read_line(session) == NULL)
- ^~~~
- clientid.c:66:38: note: 'NULL' is defined in header '<stddef.h>'; did you forget to '#include <stddef.h>'?
- clientid.c:39:1:
- +#include <stddef.h>
-
- clientid.c:66:38:
- if (mailimap_read_line(session) == NULL)
-
-diff --git a/src/low-level/imap/clientid.c b/src/low-level/imap/clientid.c
-index 1c34637..38880dd 100644
---- a/src/low-level/imap/clientid.c
-+++ b/src/low-level/imap/clientid.c
-@@ -33,6 +33,8 @@
- # include <config.h>
- #endif
-
-+#include <stdlib.h>
-+
- #include "mailimap_sender.h"
- #include "clientid_sender.h"
- #include "clientid.h"
diff --git a/net-libs/libetpan/libetpan-1.9.3.ebuild b/net-libs/libetpan/libetpan-1.9.3.ebuild
deleted file mode 100644
index 8fb6d3cd1d90..000000000000
--- a/net-libs/libetpan/libetpan-1.9.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools
-
-DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
-HOMEPAGE="http://libetpan.sourceforge.net/"
-SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="berkdb gnutls ipv6 liblockfile libressl lmdb sasl ssl static-libs"
-
-# BerkDB is only supported up to version 6.0
-DEPEND="sys-libs/zlib
- !lmdb? ( berkdb? ( <sys-libs/db-6.1:= ) )
- lmdb? ( dev-db/lmdb )
- ssl? (
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- )
- sasl? ( dev-libs/cyrus-sasl:2 )
- liblockfile? ( net-libs/liblockfile )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0-nonnull.patch
- "${FILESDIR}"/${PN}-1.9.3-missing-stddev_h.patch
-)
-
-pkg_pretend() {
- if use gnutls && ! use ssl ; then
- ewarn "You have \"gnutls\" USE flag enabled but \"ssl\" USE flag disabled!"
- ewarn "No ssl support will be available in ${PN}."
- fi
-
- if use berkdb && use lmdb ; then
- ewarn "You have \"berkdb\" _and_ \"lmdb\" USE flags enabled."
- ewarn "Using lmdb as cache DB!"
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
- # libtool recognises it as valid shell (bug #300211)
- use prefix && export CONFIG_SHELL=${BASH}
- local myeconfargs=(
- # --enable-debug simply injects "-O2 -g" into CFLAGS
- --disable-debug
- $(use_enable berkdb db)
- $(use_enable ipv6)
- $(use_enable liblockfile lockfile)
- $(use_enable lmdb)
- $(use_enable static-libs static)
- $(use_with sasl)
- $(usex ssl "$(use_with gnutls) $(use_with !gnutls openssl)" '--without-gnutls --without-openssl')
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${ED}" -name "*.la" -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
-}
diff --git a/net-libs/libetpan/libetpan-1.9.4.ebuild b/net-libs/libetpan/libetpan-1.9.4.ebuild
deleted file mode 100644
index 373a43129b37..000000000000
--- a/net-libs/libetpan/libetpan-1.9.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools
-
-DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
-HOMEPAGE="http://libetpan.sourceforge.net/"
-SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="berkdb gnutls ipv6 liblockfile libressl lmdb sasl ssl static-libs"
-
-# BerkDB is only supported up to version 6.0
-DEPEND="sys-libs/zlib
- !lmdb? ( berkdb? ( sys-libs/db:= ) )
- lmdb? ( dev-db/lmdb )
- ssl? (
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- )
- sasl? ( dev-libs/cyrus-sasl:2 )
- liblockfile? ( net-libs/liblockfile )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0-nonnull.patch
- "${FILESDIR}"/${PN}-1.9.4-berkdb_lookup.patch #519846
- "${FILESDIR}"/${PN}-1.9.4-pkgconfig_file_no_ldflags.patch
-)
-
-pkg_pretend() {
- if use gnutls && ! use ssl ; then
- ewarn "You have \"gnutls\" USE flag enabled but \"ssl\" USE flag disabled!"
- ewarn "No ssl support will be available in ${PN}."
- fi
-
- if use berkdb && use lmdb ; then
- ewarn "You have \"berkdb\" _and_ \"lmdb\" USE flags enabled."
- ewarn "Using lmdb as cache DB!"
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
- # libtool recognises it as valid shell (bug #300211)
- use prefix && export CONFIG_SHELL=${BASH}
- local myeconfargs=(
- # --enable-debug simply injects "-O2 -g" into CFLAGS
- --disable-debug
- $(use_enable ipv6)
- $(use_enable liblockfile lockfile)
- $(use_enable static-libs static)
- $(use_with sasl)
- $(usex lmdb '--enable-lmdb --disable-db' "$(use_enable berkdb db) --disable-lmdb")
- $(usex ssl "$(use_with gnutls) $(use_with !gnutls openssl)" '--without-gnutls --without-openssl')
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${ED}" -name "*.la" -delete || die
- if ! use static-libs ; then
- find "${ED}" -name "*.a" -delete || die
- fi
-}