summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ansi2html/Manifest2
-rw-r--r--dev-python/ansi2html/ansi2html-1.4.2.ebuild49
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.1.ebuild45
-rw-r--r--dev-python/ansi2html/ansi2html-1.5.2.ebuild45
4 files changed, 0 insertions, 141 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index f1c966afae99..02afa9749333 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1,3 +1 @@
-DIST ansi2html-1.4.2.tar.gz 25485 BLAKE2B 93f3bbd307b916c9ca60379235600606dbe16f1b6e423d0d2615f7825e92a6d7a8469ae7d60cf5131b4c3431897b3161bfcd2a0327525a332bcd6a6980dad5c9 SHA512 29c569839788968ba5a1fed8dddd4cc92f40ca88b4135b597815012ea44a44e8b7a3c2259d2d5d5f3cc690400be882236b88c0764a649da5679431501aab0b1c
-DIST ansi2html-1.5.1.tar.gz 27133 BLAKE2B 8a8017b8f4edb878b105138ec0dfe3fbde8647315382d763eeae7f90f094b60f0cb7205718c75930ccb7ca1183e40e5205eca6f8362e20445d930d92db23bc22 SHA512 367fa9721de65a6e14118d65de9ea8ede1ecc9f0809115ecccf481947aa442409ca972442e51a75bc4f14913566255142da4e411fe060dfda5e55f84a7ac67af
DIST ansi2html-1.5.2.tar.gz 27124 BLAKE2B 0d02e8cea46622c4d2cbd06f06fd31b3c7e93d61f6b9eadb37815d2ee490b6ce4233fb019f175f61465ef89520a944bbe14543627a6421a64304b58dc038c0ca SHA512 163d5784d04e6eea0847676b967051382fa74a354c19462d1b73980fd1b0a7eb45ce1f1bd88cca803356e7767ccab1bbce6de4152c98aec98534f4ed7d65a83f
diff --git a/dev-python/ansi2html/ansi2html-1.4.2.ebuild b/dev-python/ansi2html/ansi2html-1.4.2.ebuild
deleted file mode 100644
index 11e0fd4e1bc2..000000000000
--- a/dev-python/ansi2html/ansi2html-1.4.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Convert text with ANSI color codes to HTML"
-HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="doc test"
-
-# They miserably fail.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-DEPEND="
- doc? ( app-text/asciidoc )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-
-src_compile() {
- use doc && emake man/${PN}.1
- distutils-r1_src_compile
-}
-
-python_test() {
- chmod -x "${S}"/tests/* || die
- esetup.py check
- esetup.py test
-}
-
-python_install_all() {
- use doc && doman man/${PN}.1
- DOCS=( README.rst man/${PN}.1.txt )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/ansi2html/ansi2html-1.5.1.ebuild b/dev-python/ansi2html/ansi2html-1.5.1.ebuild
deleted file mode 100644
index dbe978a6042c..000000000000
--- a/dev-python/ansi2html/ansi2html-1.5.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Convert text with ANSI color codes to HTML"
-HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-python_test() {
- chmod -x "${S}"/tests/* || die
- esetup.py check
- esetup.py test
-}
-
-python_install_all() {
- doman man/${PN}.1
- DOCS=( README.rst man/${PN}.1.txt )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/ansi2html/ansi2html-1.5.2.ebuild b/dev-python/ansi2html/ansi2html-1.5.2.ebuild
deleted file mode 100644
index 8f6a5190749c..000000000000
--- a/dev-python/ansi2html/ansi2html-1.5.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Convert text with ANSI color codes to HTML"
-HOMEPAGE="https://pypi.org/project/ansi2html/ https://github.com/ralphbean/ansi2html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-python_test() {
- chmod -x "${S}"/tests/* || die
- esetup.py check
- esetup.py test
-}
-
-python_install_all() {
- doman man/${PN}.1
- DOCS=( README.rst man/${PN}.1.txt )
- distutils-r1_python_install_all
-}