summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Text-VimColor/Text-VimColor-0.260-r1.ebuild15
-rw-r--r--dev-perl/Text-VimColor/files/Text-VimColor-0.260-perl526.patch12
2 files changed, 21 insertions, 6 deletions
diff --git a/dev-perl/Text-VimColor/Text-VimColor-0.260-r1.ebuild b/dev-perl/Text-VimColor/Text-VimColor-0.260-r1.ebuild
index d997a60feda0..aa7290a59f43 100644
--- a/dev-perl/Text-VimColor/Text-VimColor-0.260-r1.ebuild
+++ b/dev-perl/Text-VimColor/Text-VimColor-0.260-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_VERSION=0.26
-MODULE_AUTHOR="RWSTAUNER"
+DIST_VERSION=0.26
+DIST_AUTHOR="RWSTAUNER"
inherit perl-module
@@ -28,6 +28,9 @@ DEPEND="${RDEPEND}
dev-perl/Path-Class
dev-perl/XML-Parser
dev-perl/Test-Pod
- )"
+ )
+"
-SRC_TEST="do"
+PATCHES=(
+ "${FILESDIR}/${P}-perl526.patch"
+)
diff --git a/dev-perl/Text-VimColor/files/Text-VimColor-0.260-perl526.patch b/dev-perl/Text-VimColor/files/Text-VimColor-0.260-perl526.patch
new file mode 100644
index 000000000000..7d7159ea3243
--- /dev/null
+++ b/dev-perl/Text-VimColor/files/Text-VimColor-0.260-perl526.patch
@@ -0,0 +1,12 @@
+diff -ruN Text-VimColor-0.26.orig/Makefile.PL Text-VimColor-0.26/Makefile.PL
+--- Text-VimColor-0.26.orig/Makefile.PL 2015-03-21 04:14:35.000000000 -0000
++++ Text-VimColor-0.26/Makefile.PL 2017-08-04 09:46:55.760799972 -0000
+@@ -12,6 +12,8 @@
+
+ use 5.006;
+
++use lib q[.];
++
+ use inc::VimCommand;
+ use ExtUtils::MakeMaker;
+