summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-apps/radeon-profile-daemon/Manifest1
-rw-r--r--x11-apps/radeon-profile-daemon/files/radeon-profile-daemon-20190309-secure_socket.patch26
-rw-r--r--x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd27
-rw-r--r--x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309-r2.ebuild60
4 files changed, 0 insertions, 114 deletions
diff --git a/x11-apps/radeon-profile-daemon/Manifest b/x11-apps/radeon-profile-daemon/Manifest
index dae73dc833e0..9a1f922d02f7 100644
--- a/x11-apps/radeon-profile-daemon/Manifest
+++ b/x11-apps/radeon-profile-daemon/Manifest
@@ -1,2 +1 @@
-DIST radeon-profile-daemon-20190309.tar.gz 12178 BLAKE2B 931ce4bb123456e349a68c8fe0b18150ff988a83a5e58cf451f68025240a8b4c802e03a567ef41684e91442bf21c02cc00d31ef6c82a67ca7eb7587754c6f32e SHA512 f2bb6f7dc0bf322e5c43c5ca1f99501a4fd3f4532cc9c1686b5cfbc58bdd423e81c25d3ae03fcae9dc15dc92d8ad089b2357b27b0ff399de7ac27213e00b2f37
DIST radeon-profile-daemon-20190603.tar.gz 12232 BLAKE2B 3ff02f76178c2a30c8f094a2589aaed7d9e2c8ecc4cd0c8d3b6be1e38dddad39bbb4996ef9b7f87ef999890fbdade6ba3c6bcc39de6ae84bf1c224152a8249f1 SHA512 1c58008400f5acc5bd39353c6e2c109adecc4eb2b5d7976ce240d372cc60996ee93ce50630292ce85b9a1ae92d82e6cce49fd0ccb28f574bc668d212c50a54ab
diff --git a/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon-20190309-secure_socket.patch b/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon-20190309-secure_socket.patch
deleted file mode 100644
index 5d7132b90b75..000000000000
--- a/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon-20190309-secure_socket.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 8e75c8678b874c6813e590634943166daa98124b Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Fri, 10 May 2019 11:01:21 +0200
-Subject: [PATCH] Don't make the socket world writable
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- radeon-profile-daemon/rpdthread.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/radeon-profile-daemon/rpdthread.cpp b/radeon-profile-daemon/rpdthread.cpp
-index 4cf0ac0..137d5b2 100644
---- a/radeon-profile-daemon/rpdthread.cpp
-+++ b/radeon-profile-daemon/rpdthread.cpp
-@@ -47,7 +47,7 @@ void rpdThread::createServer()
-
- QLocalServer::removeServer(serverName);
- daemonServer.listen(serverName);
-- QFile::setPermissions("/tmp/" + serverName, QFile("/tmp/" + serverName).permissions() | QFile::WriteOther | QFile::ReadOther);
-+ QFile::setPermissions("/tmp/" + serverName, QFile("/tmp/" + serverName).permissions() | QFile::WriteGroup | QFile::ReadGroup);
- }
-
- void rpdThread::closeConnection()
---
-2.21.0
-
diff --git a/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd b/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd
deleted file mode 100644
index adbc0195e4b0..000000000000
--- a/x11-apps/radeon-profile-daemon/files/radeon-profile-daemon.initd
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-description="Daemon for radeon-profile GUI"
-
-command="/usr/sbin/radeon-profile-daemon"
-command_background="true"
-pidfile="/run/${SVCNAME}.pid"
-
-radeon_socket="/tmp/radeon-profile-daemon-server"
-
-wait_for_socket() {
- local i=0
- while [ ${i} -lt 10 ]; do
- [ -S "${radeon_socket}" ] && return 0
- i=$((${i}+1))
- sleep 1
- done
-
- return 1
-}
-
-start_post() {
- wait_for_socket || return 1
- chgrp video ${radeon_socket}
-}
diff --git a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309-r2.ebuild b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309-r2.ebuild
deleted file mode 100644
index 924760fc9099..000000000000
--- a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-20190309-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils systemd
-
-DESCRIPTION="Daemon for radeon-profile GUI"
-HOMEPAGE="https://github.com/marazmista/radeon-profile-daemon"
-if [[ "${PV}" == 99999999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/marazmista/radeon-profile-daemon.git"
-else
- SRC_URI="https://github.com/marazmista/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE=""
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}/${PN}"
-
-PATCHES=(
- "${FILESDIR}/${P}-secure_socket.patch"
-)
-
-src_prepare() {
- eapply -p2 "${PATCHES[@]}"
- eapply_user
-
- sed \
- -e '/^bin\.path/s@/bin@/sbin@' \
- -e "/^service\.path/s@=.*\$@= $(systemd_get_systemunitdir)@" \
- -i radeon-profile-daemon.pro || die
- sed \
- -e '/^ExecStart/s@/bin/@/sbin/@' \
- -i extra/${PN}.service || die
-}
-
-src_configure() {
- eqmake5
-}
-
-src_install() {
- emake INSTALL_ROOT="${D}" install
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
-}
-
-pkg_postinst() {
- elog "Users need to be in the \"video\" group if they want to change"
- elog "video card settings via ${PN}"
-}