summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/genkernel/files/genkernel-3.4.52.4-crc32c.patch130
-rw-r--r--sys-kernel/genkernel/genkernel-3.4.52.4-r3.ebuild157
2 files changed, 287 insertions, 0 deletions
diff --git a/sys-kernel/genkernel/files/genkernel-3.4.52.4-crc32c.patch b/sys-kernel/genkernel/files/genkernel-3.4.52.4-crc32c.patch
new file mode 100644
index 000000000000..48dada2f980d
--- /dev/null
+++ b/sys-kernel/genkernel/files/genkernel-3.4.52.4-crc32c.patch
@@ -0,0 +1,130 @@
+modules_load: add crc32c
+
+commit 7308d72c3280da22cd94337b0eb248cdc53cb842 upstream.
+
+Bug: https://bugs.gentoo.org/655110
+
+--- a/arch/alpha/modules_load
++++ b/arch/alpha/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/arm/modules_load
++++ b/arch/arm/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/ia64/modules_load
++++ b/arch/ia64/modules_load
+@@ -26,3 +26,6 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
++
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/mips/modules_load
++++ b/arch/mips/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/parisc/modules_load
++++ b/arch/parisc/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/parisc64/modules_load
++++ b/arch/parisc64/modules_load
+@@ -26,3 +26,6 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
++
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/ppc/modules_load
++++ b/arch/ppc/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/ppc64/modules_load
++++ b/arch/ppc64/modules_load
+@@ -26,3 +26,6 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
++
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/s390/modules_load
++++ b/arch/s390/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/sparc/modules_load
++++ b/arch/sparc/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/sparc64/modules_load
++++ b/arch/sparc64/modules_load
+@@ -26,3 +26,6 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
++
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/um/modules_load
++++ b/arch/um/modules_load
+@@ -27,3 +27,5 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ # Filesystems
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
++# Crypto
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
+--- a/arch/x86/modules_load
++++ b/arch/x86/modules_load
+@@ -29,4 +29,4 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
+ # Crypto
+-MODULES_CRYPTO="sha256_generic cbc aes_generic aes_586 aesni-intel xts"
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic aes_586 aesni-intel xts"
+--- a/arch/x86_64/modules_load
++++ b/arch/x86_64/modules_load
+@@ -28,4 +28,4 @@ MODULES_USB="ehci-pci ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd x
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
+ # Crypto
+-MODULES_CRYPTO="sha256_generic cbc aes_generic aes-x86_64 aesni-intel xts"
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic aes-x86_64 aesni-intel xts"
+--- a/defaults/modules_load
++++ b/defaults/modules_load
+@@ -28,4 +28,4 @@ MODULES_USB="ehci-hcd uhci usb-ohci hid usb-storage uhci-hcd ohci-hcd xhci-hcd x
+ MODULES_FS="ext2 ext3 ext4 btrfs reiserfs jfs nfs xfs zfs fuse"
+
+ # Crypto
+-MODULES_CRYPTO="sha256_generic cbc aes_generic xts"
++MODULES_CRYPTO="sha256_generic cbc crc32c aes_generic xts"
diff --git a/sys-kernel/genkernel/genkernel-3.4.52.4-r3.ebuild b/sys-kernel/genkernel/genkernel-3.4.52.4-r3.ebuild
new file mode 100644
index 000000000000..92286851f5aa
--- /dev/null
+++ b/sys-kernel/genkernel/genkernel-3.4.52.4-r3.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# genkernel-9999 -> latest Git branch "master"
+# genkernel-VERSION -> normal genkernel release
+
+EAPI=5 # approved 2012.09.11, required by all profiles since 2014.03.12
+
+inherit bash-completion-r1 epatch
+
+VERSION_BUSYBOX='1.20.2'
+VERSION_DMRAID='1.0.0.rc16-3'
+VERSION_MDADM='3.1.5'
+VERSION_FUSE='2.8.6'
+VERSION_ISCSI='2.0-872'
+VERSION_LVM='2.02.88'
+VERSION_UNIONFS_FUSE='0.24'
+VERSION_GPG='1.4.11'
+
+RH_HOME="ftp://sourceware.org/pub"
+DM_HOME="https://people.redhat.com/~heinzm/sw/dmraid/src"
+BB_HOME="https://busybox.net/downloads"
+
+COMMON_URI="${DM_HOME}/dmraid-${VERSION_DMRAID}.tar.bz2
+ ${DM_HOME}/old/dmraid-${VERSION_DMRAID}.tar.bz2
+ mirror://kernel/linux/utils/raid/mdadm/mdadm-${VERSION_MDADM}.tar.bz2
+ ${RH_HOME}/lvm2/LVM2.${VERSION_LVM}.tgz
+ ${RH_HOME}/lvm2/old/LVM2.${VERSION_LVM}.tgz
+ ${BB_HOME}/busybox-${VERSION_BUSYBOX}.tar.bz2
+ http://www.open-iscsi.org/bits/open-iscsi-${VERSION_ISCSI}.tar.gz
+ mirror://gentoo/open-iscsi-${VERSION_ISCSI}.tar.gz
+ mirror://sourceforge/fuse/fuse-${VERSION_FUSE}.tar.gz
+ http://podgorny.cz/unionfs-fuse/releases/unionfs-fuse-${VERSION_UNIONFS_FUSE}.tar.bz2
+ mirror://gentoo/unionfs-fuse-${VERSION_UNIONFS_FUSE}.tar.bz2
+ mirror://gnupg/gnupg/gnupg-${VERSION_GPG}.tar.bz2"
+
+if [[ ${PV} == 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}"
+ SRC_URI="${COMMON_URI}"
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz
+ ${COMMON_URI}"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+fi
+
+DESCRIPTION="Gentoo automatic kernel building scripts"
+HOMEPAGE="https://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="cryptsetup ibm selinux"
+
+DEPEND="sys-fs/e2fsprogs
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${DEPEND}
+ cryptsetup? ( sys-fs/cryptsetup )
+ app-arch/cpio
+ >=app-misc/pax-utils-0.2.1
+ !<sys-apps/openrc-0.9.9"
+# pax-utils is used for lddtree
+
+if [[ ${PV} == 9999* ]]; then
+ DEPEND="${DEPEND} app-text/asciidoc"
+fi
+
+pkg_pretend() {
+ if ! use cryptsetup && has_version "sys-kernel/genkernel[crypt]"; then
+ ewarn "Local use flag 'crypt' has been renamed to 'cryptsetup' (bug #414523)."
+ ewarn "Please set flag 'cryptsetup' for this very package if you would like"
+ ewarn "to have genkernel create an initramfs with LUKS support."
+ ewarn "Sorry for the inconvenience."
+ echo
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} == 9999* ]] ; then
+ einfo "Producing ChangeLog from Git history..."
+ pushd "${S}/.git" >/dev/null || die
+ git log > "${S}"/ChangeLog || die
+ popd >/dev/null || die
+ fi
+ if use selinux ; then
+ sed -i 's/###//g' "${S}"/gen_compile.sh || die
+ fi
+
+ # Update software.sh
+ sed -i \
+ -e "s:VERSION_BUSYBOX:$VERSION_BUSYBOX:" \
+ -e "s:VERSION_MDADM:$VERSION_MDADM:" \
+ -e "s:VERSION_DMRAID:$VERSION_DMRAID:" \
+ -e "s:VERSION_FUSE:$VERSION_FUSE:" \
+ -e "s:VERSION_ISCSI:$VERSION_ISCSI:" \
+ -e "s:VERSION_LVM:$VERSION_LVM:" \
+ -e "s:VERSION_UNIONFS_FUSE:$VERSION_UNIONFS_FUSE:" \
+ -e "s:VERSION_GPG:$VERSION_GPG:" \
+ "${S}"/defaults/software.sh \
+ || die "Could not adjust versions"
+
+ epatch "${FILESDIR}"/${P}-system-map.patch #570822
+ epatch "${FILESDIR}"/${P}-grub-mkconfig.patch #591200
+ epatch "${FILESDIR}"/${P}-crc32c.patch #655110
+ epatch_user
+}
+
+src_compile() {
+ if [[ ${PV} == 9999* ]]; then
+ emake
+ fi
+}
+
+src_install() {
+ insinto /etc
+ doins "${S}"/genkernel.conf
+
+ doman genkernel.8
+ dodoc AUTHORS ChangeLog README TODO
+ dobin genkernel
+ rm -f genkernel genkernel.8 AUTHORS ChangeLog README TODO genkernel.conf
+
+ if use ibm ; then
+ cp "${S}"/arch/ppc64/kernel-2.6{-pSeries,} || die
+ else
+ cp "${S}"/arch/ppc64/kernel-2.6{.g5,} || die
+ fi
+ insinto /usr/share/genkernel
+ doins -r "${S}"/*
+
+ newbashcomp "${FILESDIR}"/genkernel.bash "${PN}"
+ insinto /etc
+ doins "${FILESDIR}"/initramfs.mounts
+
+ cd "${DISTDIR}"
+ insinto /usr/share/genkernel/distfiles
+ doins ${A/${P}.tar.xz/}
+}
+
+pkg_postinst() {
+ echo
+ elog 'Documentation is available in the genkernel manual page'
+ elog 'as well as the following URL:'
+ echo
+ elog 'https://wiki.gentoo.org/wiki/Genkernel'
+ echo
+ ewarn "This package is known to not work with reiser4. If you are running"
+ ewarn "reiser4 and have a problem, do not file a bug. We know it does not"
+ ewarn "work and we don't plan on fixing it since reiser4 is the one that is"
+ ewarn "broken in this regard. Try using a sane filesystem like ext4."
+ echo
+ ewarn "The LUKS support has changed from versions prior to 3.4.4. Now,"
+ ewarn "you use crypt_root=/dev/blah instead of real_root=luks:/dev/blah."
+ echo
+}