summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/tpm2-tss-engine/Manifest1
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss-engine/Manifest b/app-crypt/tpm2-tss-engine/Manifest
index 6450c0c47e12..e1c91bb45b81 100644
--- a/app-crypt/tpm2-tss-engine/Manifest
+++ b/app-crypt/tpm2-tss-engine/Manifest
@@ -1 +1,2 @@
+DIST tpm2-tss-engine-1.1.0.tar.gz 394448 BLAKE2B 0502907dc9ce872f31be3b980f975a02af2e3e4b369d188afa5327bd4475d93dbf43769dc7ddc11e8cbda8d1fde09f28a9aef9145e859a90225cd397f62c7a2c SHA512 5d2e08178be54350e8672245023d601a0d9d520f8c49e977af49d7c59b91d033c14b4a347b71e042fe7c5ff12af9fcc43b69fd1dc83a9f0db12d47d43e1107f4
DIST tpm2-tss-engine-1.1.0_rc1.tar.gz 38749 BLAKE2B 74063555404f2c61a21ba05f0eb1217fa78db4296d48712dccf1a113f5b7edef3d10f3347b955562a97f974342eeecdedebf0f2073551c4d0e4277b8320f72b7 SHA512 e5620886c3b27fea3a51ff136bddaa6eb5d57277ca29a79964cd600703b03447341a535bb46079c15caf96cfe6f45943322b2f2dd0c48f453d6b9c57e76989bc
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild
new file mode 100644
index 000000000000..81489aec4e68
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="OpenSSL Engine for TPM2 devices"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/tpm2-tss
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --disable-static \
+ --with-completionsdir="$(get_bashcompdir)"
+}
+
+src_install () {
+ default
+ dobashcomp bash-completion/*
+}