summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/qgis/Manifest3
-rw-r--r--sci-geosciences/qgis/files/qgis-2.18.12-sip.patch185
-rw-r--r--sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch31
-rw-r--r--sci-geosciences/qgis/qgis-2.18.12.ebuild209
-rw-r--r--sci-geosciences/qgis/qgis-2.18.16.ebuild207
5 files changed, 0 insertions, 635 deletions
diff --git a/sci-geosciences/qgis/Manifest b/sci-geosciences/qgis/Manifest
index 12f160796e27..1834d00be284 100644
--- a/sci-geosciences/qgis/Manifest
+++ b/sci-geosciences/qgis/Manifest
@@ -1,5 +1,2 @@
-DIST qgis-2.18.12.tar.bz2 84936155 BLAKE2B 0d47094ae8dac3101888140b5773a8e7b52d2562517bb30983592043267adc28d878ad644162ad04d84440497c567d075225db3db5a215440dee7258a8faade3 SHA512 e34dd98d0d0aa5fdf1f980dbc1376c25a9a7ffaa59b1a2eba8423e7f44bc039b547f3f65368178a8c485fa34526dd9fece2e09d9372fed3b9a758f7286b690ea
-DIST qgis-2.18.16.tar.bz2 84976777 BLAKE2B ad68ce63698266bc081db7be0529ef50f66ee9c048b2e2a743cfc24d1ddb161c86c71283c09740a22c45476f863516f8855c69a5ccf074e9676d1ed5a09563a1 SHA512 1fe060c1d392f304eea10a211815e14081299a865e34114625f3a5f2a1b365f571bb30878a21cbf25bc32285ffc689d37cb7dbcab129ce5f03ccd6fa0781876d
DIST qgis-3.0.1.tar.bz2 94217493 BLAKE2B 9f3b9e9d76dfac574cbe7c9b95f0dc59fb9ad74ddd5c5a420931107200b1ba6641e2b74cff681ecec8cdab777cda69c0e698fa952bc28cd79c761f4636f62f00 SHA512 c07fc9b033fa043e38098d226dac69ea35890109c45ccc4c47017e0af2d3fbed4b1a71b3fd7dc76fea3eb43fbcdbfb660df50d779da8c43f68a4402b239f8f75
DIST qgis_sample_data-2.8.14.tar.gz 22119181 BLAKE2B 2d0565e91ec8119382bc9ab8e262dc04227fe8289146794891759ff5a32012245270614ba1119a6329fc45cf56852830c2079589309aa3467873f71f5c608eac SHA512 6b2653d5b57ffc2c2317639dac212429840984ac917ca3e452b39aabb99ea106d1a77c1c1dd967244ef16ede9deae751b170affdf08b72239eafed5b8977da3d
-DIST qgis_sample_data.tar.gz 13601736 BLAKE2B 92acadbd009b181e74516120b3a700c96c7c1a732240434439bbe51afa441dee6521dac7bf6629fb5d7489b63fd0e0a45b1871df099820e8cd594920fa1499b7 SHA512 5847d7b32e5f75e771adf6b959847024f55b2360c307bd80e5628595fc53f5aaca18adf6cb00fa027a7e7b326c7f72bab58df16674daf20b77c676e163d93f78
diff --git a/sci-geosciences/qgis/files/qgis-2.18.12-sip.patch b/sci-geosciences/qgis/files/qgis-2.18.12-sip.patch
deleted file mode 100644
index 07db9b029bf6..000000000000
--- a/sci-geosciences/qgis/files/qgis-2.18.12-sip.patch
+++ /dev/null
@@ -1,185 +0,0 @@
-diff --git a/python/core/conversions.sip b/python/core/conversions.sip
-index f07d3ab1db..948821e91e 100644
---- a/python/core/conversions.sip
-+++ b/python/core/conversions.sip
-@@ -2041,3 +2041,178 @@ register_from_qvariant_convertor = (void (*)(FromQVariantConvertorFn))sipImportS
- register_from_qvariant_convertor(null_from_qvariant_convertor);
- %End
- %End
-+
-+// QList<QVariant> is implemented as a Python list.
-+%MappedType QList<QVariant> /TypeHintIn="Sequence[QVariant]", TypeHintOut="List[QVariant]", TypeHintValue="[]"/
-+{
-+%TypeHeaderCode
-+#include <qlist.h>
-+%End
-+
-+%ConvertFromTypeCode
-+ // Create the list.
-+ PyObject *l;
-+
-+ if ((l = PyList_New(sipCpp->size())) == NULL)
-+ return NULL;
-+
-+ // Set the list elements.
-+ for (int i = 0; i < sipCpp->size(); ++i)
-+ {
-+ QVariant *t = new QVariant(sipCpp->at(i));
-+ PyObject *tobj;
-+
-+ if ((tobj = sipConvertFromNewType(t, sipType_QVariant, sipTransferObj)) == NULL)
-+ {
-+ Py_DECREF(l);
-+ delete t;
-+
-+ return NULL;
-+ }
-+
-+ PyList_SET_ITEM(l, i, tobj);
-+ }
-+
-+ return l;
-+%End
-+
-+%ConvertToTypeCode
-+ SIP_SSIZE_T len;
-+
-+ // Check the type if that is all that is required.
-+ if (sipIsErr == NULL)
-+ {
-+ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
-+ return 0;
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ bool ok = (itm && sipCanConvertToType(itm, sipType_QVariant, SIP_NOT_NONE));
-+
-+ Py_XDECREF(itm);
-+
-+ if (!ok)
-+ return 0;
-+ }
-+
-+ return 1;
-+ }
-+
-+ QList<QVariant> *ql = new QList<QVariant>;
-+ len = PySequence_Size(sipPy);
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ int state;
-+ QVariant *t = reinterpret_cast<QVariant *>(sipConvertToType(itm, sipType_QVariant, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
-+
-+ Py_DECREF(itm);
-+
-+ if (*sipIsErr)
-+ {
-+ sipReleaseType(t, sipType_QVariant, state);
-+
-+ delete ql;
-+ return 0;
-+ }
-+
-+ ql->append(*t);
-+
-+ sipReleaseType(t, sipType_QVariant, state);
-+ }
-+
-+ *sipCppPtr = ql;
-+
-+ return sipGetState(sipTransferObj);
-+%End
-+};
-+
-+
-+// QList<QPolygonF> is implemented as a Python list.
-+%MappedType QList<QPolygonF> /TypeHintIn="Sequence[QPolygonF]", TypeHintOut="List[QPolygonF]", TypeHintValue="[]"/
-+{
-+%TypeHeaderCode
-+#include <qlist.h>
-+%End
-+
-+%ConvertFromTypeCode
-+ // Create the list.
-+ PyObject *l;
-+
-+ if ((l = PyList_New(sipCpp->size())) == NULL)
-+ return NULL;
-+
-+ // Set the list elements.
-+ for (int i = 0; i < sipCpp->size(); ++i)
-+ {
-+ QPolygonF *t = new QPolygonF(sipCpp->at(i));
-+ PyObject *tobj;
-+
-+ if ((tobj = sipConvertFromNewType(t, sipType_QPolygonF, sipTransferObj)) == NULL)
-+ {
-+ Py_DECREF(l);
-+ delete t;
-+
-+ return NULL;
-+ }
-+
-+ PyList_SET_ITEM(l, i, tobj);
-+ }
-+
-+ return l;
-+%End
-+
-+%ConvertToTypeCode
-+ SIP_SSIZE_T len;
-+
-+ // Check the type if that is all that is required.
-+ if (sipIsErr == NULL)
-+ {
-+ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
-+ return 0;
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ bool ok = (itm && sipCanConvertToType(itm, sipType_QPolygonF, SIP_NOT_NONE));
-+
-+ Py_XDECREF(itm);
-+
-+ if (!ok)
-+ return 0;
-+ }
-+
-+ return 1;
-+ }
-+
-+ QList<QPolygonF> *ql = new QList<QPolygonF>;
-+ len = PySequence_Size(sipPy);
-+
-+ for (SIP_SSIZE_T i = 0; i < len; ++i)
-+ {
-+ PyObject *itm = PySequence_ITEM(sipPy, i);
-+ int state;
-+ QPolygonF *t = reinterpret_cast<QPolygonF *>(sipConvertToType(itm, sipType_QPolygonF, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
-+
-+ Py_DECREF(itm);
-+
-+ if (*sipIsErr)
-+ {
-+ sipReleaseType(t, sipType_QPolygonF, state);
-+
-+ delete ql;
-+ return 0;
-+ }
-+
-+ ql->append(*t);
-+
-+ sipReleaseType(t, sipType_QPolygonF, state);
-+ }
-+
-+ *sipCppPtr = ql;
-+
-+ return sipGetState(sipTransferObj);
-+%End
-+};
---
-2.12.0
diff --git a/sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch b/sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch
deleted file mode 100644
index 0d4c99de9de0..000000000000
--- a/sci-geosciences/qgis/files/qgis-2.18.6-featuresummary.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 70505aa1569c541dd252115848f46f91811955c0 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 9 Apr 2017 20:21:28 +0200
-Subject: [PATCH 1/2] Use FeatureSummary
-
----
- CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ed0a84013a..26f4659f61 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -28,6 +28,8 @@ SET(CMAKE_COLOR_MAKEFILE ON)
- # set path to additional CMake modules
- SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
-
-+include(FeatureSummary)
-+
- # in generated makefiles use relative paths so the project dir is moveable
- # Note commented out since it cause problems but it would be nice to resolve these and enable
- #
-@@ -908,3 +910,5 @@ ENDIF(WIN32 AND NOT UNIX)
- SET(CPACK_PACKAGE_EXECUTABLES "qgis" "QGIS")
- SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_SOURCE_DIR}/README.md")
- INCLUDE(CPack)
-+
-+FEATURE_SUMMARY(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
---
-2.12.2
-
diff --git a/sci-geosciences/qgis/qgis-2.18.12.ebuild b/sci-geosciences/qgis/qgis-2.18.12.ebuild
deleted file mode 100644
index 94f4a69b124c..000000000000
--- a/sci-geosciences/qgis/qgis-2.18.12.ebuild
+++ /dev/null
@@ -1,209 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit cmake-utils eutils gnome2-utils python-single-r1 qmake-utils xdg-utils
-
-DESCRIPTION="User friendly Geographic Information System"
-HOMEPAGE="http://www.qgis.org/"
-SRC_URI="
- http://qgis.org/downloads/qgis-${PV}.tar.bz2
- examples? ( http://download.osgeo.org/qgis/data/qgis_sample_data.tar.gz )"
-
-LICENSE="GPL-2+ GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples georeferencer grass mapserver oracle postgres python"
-
-REQUIRED_USE="
- mapserver? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="
- app-crypt/qca:2[qt4,ssl]
- >=dev-db/spatialite-4.1.0
- dev-db/sqlite:3
- dev-libs/expat
- dev-libs/qjson
- dev-qt/designer:4
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtscript:4
- dev-qt/qtsvg:4
- dev-qt/qtsql:4
- sci-libs/gdal:=[geos,python?,${PYTHON_USEDEP}]
- sci-libs/geos
- sci-libs/libspatialindex:=
- sci-libs/proj
- x11-libs/qscintilla:=[qt4(-)]
- >=x11-libs/qwt-6.1.2:6=[svg,qt4(-)]
- >=x11-libs/qwtpolar-1[qt4(-)]
- georeferencer? ( sci-libs/gsl:= )
- grass? ( >=sci-geosciences/grass-7.0.0:= )
- mapserver? ( dev-libs/fcgi )
- oracle? (
- dev-db/oracle-instantclient:=
- sci-libs/gdal:=[oracle]
- )
- postgres? ( dev-db/postgresql:= )
- python? ( ${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt4[X,sql,svg,${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[qt4(-),${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sip:=[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- )
-"
-DEPEND="${COMMON_DEPEND}
- sys-devel/bison
- sys-devel/flex
-"
-RDEPEND="${COMMON_DEPEND}
- sci-geosciences/gpsbabel
-"
-
-# Disabling test suite because upstream disallow running from install path
-RESTRICT="test"
-
-PATCHES=(
- # TODO upstream
- "${FILESDIR}/${PN}-2.18.6-featuresummary.patch"
- # Taken from redhat
- "${FILESDIR}/${P}-sip.patch"
- # git master
- "${FILESDIR}/${P}-cmake-lib-suffix.patch"
-)
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e "s:\${QT_BINARY_DIR}:$(qt4_get_bindir):" \
- CMakeLists.txt || die "Failed to fix lrelease path"
-
- cd src/plugins || die
- use georeferencer || cmake_comment_add_subdirectory georeferencer
-}
-
-src_configure() {
- local mycmakeargs=(
- -DQGIS_MANUAL_SUBDIR=/share/man/
- -DBUILD_SHARED_LIBS=ON
- -DQGIS_LIB_SUBDIR=$(get_libdir)
- -DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis
- -DQWT_INCLUDE_DIR=/usr/include/qwt6
- -DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt4.so
- -DWITH_INTERNAL_QWTPOLAR=OFF
- -DPEDANTIC=OFF
- -DWITH_APIDOC=OFF
- -DWITH_QSPATIALITE=ON
- -DENABLE_TESTS=OFF
- -DWITH_GRASS=$(usex grass)
- -DWITH_SERVER=$(usex mapserver)
- -DWITH_ORACLE=$(usex oracle)
- -DWITH_POSTGRESQL=$(usex postgres)
- -DWITH_BINDINGS=$(usex python)
- -DWITH_QTWEBKIT=OFF
- )
-
- if has_version '<x11-libs/qscintilla-2.10'; then
- mycmakeargs+=(
- -DQSCINTILLA_LIBRARY=/usr/$(get_libdir)/qt4/libqscintilla2.so
- )
- fi
-
- if use grass; then
- mycmakeargs+=(
- -DWITH_GRASS7=ON
- -DGRASS_PREFIX7=/usr/$(get_libdir)/grass70
- )
- fi
-
- if use python; then
- mycmakeargs+=(
- -DBINDINGS_GLOBAL_INSTALL=ON
- -DWITH_PYSPATIALITE=ON
- -DWITH_INTERNAL_DATEUTIL=OFF
- -DWITH_INTERNAL_FUTURE=OFF
- -DWITH_INTERNAL_MARKUPSAFE=OFF
- -DWITH_INTERNAL_PYTZ=OFF
- -DWITH_INTERNAL_SIX=OFF
- -DWITH_INTERNAL_YAML=OFF
- )
- fi
-
- # bug 612956
- addpredict /dev/dri/renderD128
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- domenu debian/qgis.desktop
-
- local size type
- for size in 16 22 24 32 48 64 96 128 256; do
- newicon -s ${size} debian/${PN}-icon${size}x${size}.png ${PN}.png
- newicon -c mimetypes -s ${size} debian/${PN}-mime-icon${size}x${size}.png ${PN}-mime.png
- for type in qgs qml qlr qpt; do
- newicon -c mimetypes -s ${size} debian/${PN}-${type}${size}x${size}.png ${PN}-${type}.png
- done
- done
- newicon -s scalable images/icons/qgis_icon.svg qgis.svg
-
- insinto /usr/share/mime/packages
- doins debian/qgis.xml
-
- if use examples; then
- docinto examples
- dodoc -r "${WORKDIR}"/qgis_sample_data/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- python_optimize "${ED%/}"/usr/share/qgis/python
-
- if use grass; then
- python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
- fi
-}
-
-pkg_postinst() {
- if use postgres; then
- elog "If you don't intend to use an external PostGIS server"
- elog "you should install:"
- elog " dev-db/postgis"
- elif use python; then
- elog "Support of PostgreSQL is disabled."
- elog "But some installed python-plugins import the psycopg2 module."
- elog "If you do not need these plugins just disable them"
- elog "in the Plugins menu, else you need to set USE=\"postgres\""
- fi
-
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
diff --git a/sci-geosciences/qgis/qgis-2.18.16.ebuild b/sci-geosciences/qgis/qgis-2.18.16.ebuild
deleted file mode 100644
index 2f935622f68c..000000000000
--- a/sci-geosciences/qgis/qgis-2.18.16.ebuild
+++ /dev/null
@@ -1,207 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit cmake-utils eutils gnome2-utils python-single-r1 qmake-utils xdg-utils
-
-DESCRIPTION="User friendly Geographic Information System"
-HOMEPAGE="https://www.qgis.org/"
-SRC_URI="
- https://qgis.org/downloads/qgis-${PV}.tar.bz2
- examples? ( https://qgis.org/downloads/data/qgis_sample_data.tar.gz -> qgis_sample_data-2.8.14.tar.gz )"
-
-LICENSE="GPL-2+ GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples georeferencer grass mapserver oracle postgres python"
-
-REQUIRED_USE="
- mapserver? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="
- app-crypt/qca:2[qt4,ssl]
- >=dev-db/spatialite-4.1.0
- dev-db/sqlite:3
- dev-libs/expat
- dev-libs/qjson
- dev-qt/designer:4
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtscript:4
- dev-qt/qtsvg:4
- dev-qt/qtsql:4
- sci-libs/gdal:=[geos,python?,${PYTHON_USEDEP}]
- sci-libs/geos
- sci-libs/libspatialindex:=
- sci-libs/proj
- x11-libs/qscintilla:=[qt4(-)]
- >=x11-libs/qwt-6.1.2:6=[svg,qt4(-)]
- >=x11-libs/qwtpolar-1[qt4(-)]
- georeferencer? ( sci-libs/gsl:= )
- grass? ( >=sci-geosciences/grass-7.0.0:= )
- mapserver? ( dev-libs/fcgi )
- oracle? (
- dev-db/oracle-instantclient:=
- sci-libs/gdal:=[oracle]
- )
- postgres? ( dev-db/postgresql:= )
- python? ( ${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt4[X,sql,svg,${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/qscintilla-python[qt4(-),${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sip:=[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- )
-"
-DEPEND="${COMMON_DEPEND}
- sys-devel/bison
- sys-devel/flex
-"
-RDEPEND="${COMMON_DEPEND}
- sci-geosciences/gpsbabel
-"
-
-# Disabling test suite because upstream disallow running from install path
-RESTRICT="test"
-
-PATCHES=(
- # TODO upstream
- "${FILESDIR}/${PN}-2.18.6-featuresummary.patch"
- # git master
- "${FILESDIR}/${PN}-2.18.12-cmake-lib-suffix.patch"
-)
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e "s:\${QT_BINARY_DIR}:$(qt4_get_bindir):" \
- CMakeLists.txt || die "Failed to fix lrelease path"
-
- cd src/plugins || die
- use georeferencer || cmake_comment_add_subdirectory georeferencer
-}
-
-src_configure() {
- local mycmakeargs=(
- -DQGIS_MANUAL_SUBDIR=/share/man/
- -DBUILD_SHARED_LIBS=ON
- -DQGIS_LIB_SUBDIR=$(get_libdir)
- -DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis
- -DQWT_INCLUDE_DIR=/usr/include/qwt6
- -DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt4.so
- -DWITH_INTERNAL_QWTPOLAR=OFF
- -DPEDANTIC=OFF
- -DWITH_APIDOC=OFF
- -DWITH_QSPATIALITE=ON
- -DENABLE_TESTS=OFF
- -DWITH_GRASS=$(usex grass)
- -DWITH_SERVER=$(usex mapserver)
- -DWITH_ORACLE=$(usex oracle)
- -DWITH_POSTGRESQL=$(usex postgres)
- -DWITH_BINDINGS=$(usex python)
- -DWITH_QTWEBKIT=OFF
- )
-
- if has_version '<x11-libs/qscintilla-2.10'; then
- mycmakeargs+=(
- -DQSCINTILLA_LIBRARY=/usr/$(get_libdir)/qt4/libqscintilla2.so
- )
- fi
-
- if use grass; then
- mycmakeargs+=(
- -DWITH_GRASS7=ON
- -DGRASS_PREFIX7=/usr/$(get_libdir)/grass70
- )
- fi
-
- if use python; then
- mycmakeargs+=(
- -DBINDINGS_GLOBAL_INSTALL=ON
- -DWITH_PYSPATIALITE=ON
- -DWITH_INTERNAL_DATEUTIL=OFF
- -DWITH_INTERNAL_FUTURE=OFF
- -DWITH_INTERNAL_MARKUPSAFE=OFF
- -DWITH_INTERNAL_PYTZ=OFF
- -DWITH_INTERNAL_SIX=OFF
- -DWITH_INTERNAL_YAML=OFF
- )
- fi
-
- # bug 612956
- addpredict /dev/dri/renderD128
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- domenu debian/qgis.desktop
-
- local size type
- for size in 16 22 24 32 48 64 96 128 256; do
- newicon -s ${size} debian/${PN}-icon${size}x${size}.png ${PN}.png
- newicon -c mimetypes -s ${size} debian/${PN}-mime-icon${size}x${size}.png ${PN}-mime.png
- for type in qgs qml qlr qpt; do
- newicon -c mimetypes -s ${size} debian/${PN}-${type}${size}x${size}.png ${PN}-${type}.png
- done
- done
- newicon -s scalable images/icons/qgis_icon.svg qgis.svg
-
- insinto /usr/share/mime/packages
- doins debian/qgis.xml
-
- if use examples; then
- docinto examples
- dodoc -r "${WORKDIR}"/qgis_sample_data/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- python_optimize "${ED%/}"/usr/share/qgis/python
-
- if use grass; then
- python_fix_shebang "${ED%/}"/usr/share/qgis/grass/scripts
- fi
-}
-
-pkg_postinst() {
- if use postgres; then
- elog "If you don't intend to use an external PostGIS server"
- elog "you should install:"
- elog " dev-db/postgis"
- elif use python; then
- elog "Support of PostgreSQL is disabled."
- elog "But some installed python-plugins import the psycopg2 module."
- elog "If you do not need these plugins just disable them"
- elog "in the Plugins menu, else you need to set USE=\"postgres\""
- fi
-
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}