summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pymdown-lexers/Manifest1
-rw-r--r--dev-python/pymdown-lexers/metadata.xml20
-rw-r--r--dev-python/pymdown-lexers/pymdown-lexers-0_pre20180905.ebuild24
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pymdown-lexers/Manifest b/dev-python/pymdown-lexers/Manifest
new file mode 100644
index 000000000000..d1be47278bb9
--- /dev/null
+++ b/dev-python/pymdown-lexers/Manifest
@@ -0,0 +1 @@
+DIST pymdown-lexers-0_pre20180905.tar.gz 2596 BLAKE2B ff08ac12fbb242ab5b51b80f91d18281cf8cd9bf121b1a6d389ef47a069c614991d6fb99ff05cca9802e68b4dfc2c89d9f6d4b02051a133968ab9ee24943756b SHA512 d0a509cdd9924053b79259b873ec3a3671869b37f7a97112370d21c360f6315961d13610cf08a00e10f58d5e25ac360b3844fc997392dfe724ec14f02a079596
diff --git a/dev-python/pymdown-lexers/metadata.xml b/dev-python/pymdown-lexers/metadata.xml
new file mode 100644
index 000000000000..c0315f8bfff0
--- /dev/null
+++ b/dev-python/pymdown-lexers/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facelessuser/pymdown-lexers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymdown-lexers/pymdown-lexers-0_pre20180905.ebuild b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20180905.ebuild
new file mode 100644
index 000000000000..ab51a2552894
--- /dev/null
+++ b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20180905.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+COMMIT="fa422cb95b794157760259c5c20a1235e4a459be"
+
+DESCRIPTION="Additional lexers for use in Pygments"
+HOMEPAGE="https://github.com/facelessuser/pymdown-lexers"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pygments-2.0.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"