summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/geopy/Manifest1
-rw-r--r--dev-python/geopy/geopy-1.11.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/geopy/Manifest b/dev-python/geopy/Manifest
index 2900b61d4801..0d9e20af9d7e 100644
--- a/dev-python/geopy/Manifest
+++ b/dev-python/geopy/Manifest
@@ -1,3 +1,4 @@
DIST geopy-1.10.0.tar.gz 69671 SHA256 d1445731b20762b4e1d13e98d6370ff39a58fb29bd526afe1a44d510e91ee815 SHA512 943eb188090597786d5df9d1dac652dda81dd85d8edc57d9ffd4197b8a9a89c54a01ae4d6263eae64f69dc8437234a1ca797e869856d978c367b8db4c2c82f54 WHIRLPOOL f996abff6aaab85b98267d39c9284cb45e0d5d636e8df14baa8bae8b67c97ca8472076fac5f30fae0f19a7a390ae6247afcac3afc91d14197f51d44249ce6eb2
+DIST geopy-1.11.0.tar.gz 72035 SHA256 4602a662855656551dec7bf86868f1557cc3435b7ff6bbb607f26a86dee5b718 SHA512 b3abbf0ce4ca08eadc03a97876a662bbda1901660ea03329aace30bfb5f8af17c82653273e4d2eab9aca5e817f50768dd742b4865083709e10b8599331d5573b WHIRLPOOL 2016a26bffc07e8c1466331f017cbdf04299aab6bf81cb715538ac766bf2beeba97d2fac42856f44f9701040807727e09fa18fcdb757b5406c4e50a9e710347a
DIST geopy-1.8.1.tar.gz 67542 SHA256 63b805535cbe178367ee8f5e0221fab9fa691eef5797decac1e0851d16173dcf SHA512 0df2e67ed35d5cc3f796e3188df3a37d8fa101a4b6feb6b760ea08087ba44c350765a8c1032012b5e762454fa15c520f97d59ff942f07047927ef4872232a57c WHIRLPOOL 44c3f68a26ba23ca3ffae52dba5dc575a1cf54a53ea1e39d9566d97c58bcdb26b98934befc7cf012adbd266cee8a10b72d6880d1765af7f23486292b249c91a2
DIST geopy-1.9.1.tar.gz 67158 SHA256 e95989f5baf2cc5c2cee6186355f24b3fa8ce01faabea4e2bfcb083109416462 SHA512 ad6281626a03778754bec2e776419327609b3e6e47d6641520787ed2af87106fb2842a89667da680317a6c745970ac23b66c9b0fe8e50a2d223fc3169fe013b9 WHIRLPOOL e0f6fef1a061ff2d88e6ea1a37786405b1b0cac7d0982cb7bd650582b10726a6fa682c9c6577be6cec1d90b52d3f4828d221ac07d4aff6b04b93ff95f2c69110
diff --git a/dev-python/geopy/geopy-1.11.0.ebuild b/dev-python/geopy/geopy-1.11.0.ebuild
new file mode 100644
index 000000000000..52550f3460f5
--- /dev/null
+++ b/dev-python/geopy/geopy-1.11.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Geocoding Toolbox for Python"
+HOMEPAGE="http://www.geopy.org/ https://github.com/geopy/geopy"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="test doc timezone yahoo"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="yahoo? ( >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
+ dev-python/placefinder[${PYTHON_USEDEP}] )
+ timezone? ( dev-python/pytz[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}] )
+ doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/python-docs-2.7.6-r1:2.7 )"
+
+REQUIRED_USE="test? ( yahoo timezone )"
+
+python_prepare_all() {
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+
+ # prevent install of test folder to avoid file collisions
+ sed -e "s:find_packages():find_packages(exclude=['test','test.*']):" -i setup.py || die
+}
+
+python_test() {
+ # broken tests
+ rm test/geocoders/openmapquest.py
+ sed -i -e 's/from .openmapquest import OpenMapQuestTestCase//' test/geocoders/__init__.py
+ # Ignore rogue class IGNFranceTestCase demanding elements beyond a normal testsuite
+ # i.e. "You should provide an api key and a username with a password"
+ # Cannot decipher how to skip or exclude this "context=IGNFranceTestCase"
+ # It appears it MAY stem from nose rather than geopy's suite
+ nosetests --verbose || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}