summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/jansson/Manifest1
-rw-r--r--dev-libs/jansson/jansson-2.11.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/jansson/Manifest b/dev-libs/jansson/Manifest
index 352a7fe5c0e3..0144e783563d 100644
--- a/dev-libs/jansson/Manifest
+++ b/dev-libs/jansson/Manifest
@@ -1 +1,2 @@
DIST jansson-2.10.tar.gz 487855 BLAKE2B b1d83ad1a37e66cb7c497284a7958882d5a7e13cec2260d9cc2b5eaef648feea66b70305dec9193f10cf77f37bdda17605277ea41735708ca6a9898b79fef807 SHA512 e331d5c097b4acb0b1df7d90d1d3453c26bd34bfe2e06af0027665bee9efecc2bc61cc7ab5b70dab1262bf80a3315ffb53b4176874fe07e20eee4b9ea7071d44
+DIST jansson-2.11.tar.gz 483686 BLAKE2B 873283a1b41eef1c57fbcb3d4cdb8c33b850d95ee93c800cbcc009e3e9c9e87278beff11800e63894087e51c767dcbd555fbde48163376d53be2bf72b2eac72d SHA512 0ae77cf7ec264536313639458ba20b66e221078cddd209df3ce45c895b897799954abc1ca4b0d5993b974135652804be6bede2825503469d56303470888382f8
diff --git a/dev-libs/jansson/jansson-2.11.ebuild b/dev-libs/jansson/jansson-2.11.ebuild
new file mode 100644
index 000000000000..682c09bc583d
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}