summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/md6sum/md6sum-1.0-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-crypt/md6sum/md6sum-1.0-r2.ebuild b/app-crypt/md6sum/md6sum-1.0-r2.ebuild
index 631b65b9a6e8..5859b5ca9af3 100644
--- a/app-crypt/md6sum/md6sum-1.0-r2.ebuild
+++ b/app-crypt/md6sum/md6sum-1.0-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit flag-o-matic
DESCRIPTION="A C implementation of MD6"
HOMEPAGE="https://groups.csail.mit.edu/cis/md6"
@@ -16,3 +17,8 @@ PATCHES=(
"${FILESDIR}/${P}-cflags.patch"
"${FILESDIR}/${P}-format-security.patch"
)
+
+src_configure() {
+ append-cflags -fcommon # bug #706780
+ default
+}