summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.31.ebuild56
-rw-r--r--dev-python/boto3/boto3-9999.ebuild6
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 86a7f65aab56..3d3ad6db5012 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.14.20.tar.gz 299325 BLAKE2B e1105a2ba55d59dc4d9a73f40e3bc34c05ceda9
DIST boto3-1.14.23.tar.gz 299581 BLAKE2B 57cbb3fbd9a84f334b5874ca96490cb0269bb79f3fd2b50d4c51efcfadaa41b2e11853266ba12544b77999fa85fefb0bdf84d924667c4092b3deb72f41e33a21 SHA512 263b2abf3c220d3fb3d7acf4cd87266c11d3dcd5d7ffcafb0aab128b1e324d6f99c44de8abfb621b153b5fc51b9823b6b79ea5c529f6c59c548c900015bcdb5e
DIST boto3-1.14.27.tar.gz 299871 BLAKE2B b0bca67cc43af0eb6d823ddf256e219c1137793a211c9f02fcbcba364887882496c98d1463b899c68e65127b2ddb3a4781f93237365a2fc539ba07b43714479e SHA512 3576d0ebe1167cf6ce9decd1efd9c55c5e06074303da38bee236c8f0bf1fb0ae459e88ae5719590a0e7aa02936277e5c08a35e5bf08249f50716b6147f7872a4
DIST boto3-1.14.28.tar.gz 299959 BLAKE2B 7318fd60ccd46e12f38eb14aeecfb59fd951ed9749990f2b7bfc991b2a5077d2afe93a37b28f833ec232e85cd85a454887672be3b6b72b37e696677c45c9287c SHA512 e83695d00f2d08ad129be24f2a387fcd7181f727bd4c64df1d3d8a14aff280388262032b60f7a01829ffcaeb639eeebc9e1e85a786f3228e1d28ed4d15166ca7
+DIST boto3-1.14.31.tar.gz 300720 BLAKE2B 9dbd002e299c629f28037572c615a00612c80773006c344797d0ad56c81c240b56bfc56e8ffe52e3b404c77a56318532aadfa2d008c254e70f7bfa91e40b7e1a SHA512 e3fe0041bbdc67affcf5d5272c26aa14ef0fa546af2efb99187311bee23531181ab1f1ebc69f2c3ed8250140642f4402334ebbc9acbf422641fa6abed5d5815f
diff --git a/dev-python/boto3/boto3-1.14.31.ebuild b/dev-python/boto3/boto3-1.14.31.ebuild
new file mode 100644
index 000000000000..74bb826bd085
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.31.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/boto3/boto3-9999.ebuild b/dev-python/boto3/boto3-9999.ebuild
index 4e13937c40ec..74bb826bd085 100644
--- a/dev-python/boto3/boto3-9999.ebuild
+++ b/dev-python/boto3/boto3-9999.ebuild
@@ -14,13 +14,17 @@ SLOT="0"
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
inherit git-r3
+ BOTOCORE_PV=${PV}
else
SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
fi
RDEPEND="
- >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
"