summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/strace/strace-4.22.ebuild1
-rw-r--r--dev-util/strace/strace-9999.ebuild3
2 files changed, 3 insertions, 1 deletions
diff --git a/dev-util/strace/strace-4.22.ebuild b/dev-util/strace/strace-4.22.ebuild
index e7b555a3e2b0..9fd23499e4d2 100644
--- a/dev-util/strace/strace-4.22.ebuild
+++ b/dev-util/strace/strace-4.22.ebuild
@@ -44,6 +44,7 @@ src_prepare() {
fi
filter-lfs-flags # configure handles this sanely
+ # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
use static && append-ldflags -static -pthread
export ac_cv_header_libaio_h=$(usex aio)
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index bcf676fc5d5e..9a46478721fc 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -44,7 +44,8 @@ src_prepare() {
fi
filter-lfs-flags # configure handles this sanely
- use static && append-ldflags -static
+ # Add -pthread since strace wants -lrt for timer_create, and -lrt uses -lpthread.
+ use static && append-ldflags -static -pthread
export ac_cv_header_libaio_h=$(usex aio)
use elibc_musl && export ac_cv_header_stdc=no