summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyinsane/Manifest1
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.12.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyinsane/Manifest b/dev-python/pyinsane/Manifest
index 3d5f801836a6..25b964bc6884 100644
--- a/dev-python/pyinsane/Manifest
+++ b/dev-python/pyinsane/Manifest
@@ -1 +1,2 @@
DIST pyinsane-2.0.10.tar.gz 327159 BLAKE2B ae63e08fc557513ccac0633fac47bb29b3c8a023c481289ec60724f5fcdae0827e02d5f37d3f104d454ebcb1d1a7681248866461bce6201f056c988f858aa0d3 SHA512 bb882ab51c1e6cea7cad75851ffe5918ee08467d4772d27c23a0c5ec9f2dea3ee7d83601ae35e56e2f717ff7683cec5a45aa47b2a4e167fe4dddb9db3229a3b1
+DIST pyinsane-2.0.12.tar.gz 333115 BLAKE2B 9f0e557fe597acd34755868b90505ba77b79e883ceefda7709712c7ef9f5bdc4429e4b848520a3997948fb2a3f94096b5364acd4cdfbc3f0c9ec8bc364dfd243 SHA512 284508ce88d2619ba59b3cda56e2e2fa74d8db5ef5ef490ab93d0b14592ed6f2a6574f7dd108ccb23dc69d6d90701146cf42cf8ebf0fb56d1755e4c86df9fe86
diff --git a/dev-python/pyinsane/pyinsane-2.0.12.ebuild b/dev-python/pyinsane/pyinsane-2.0.12.ebuild
new file mode 100644
index 000000000000..49ee194e7e56
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/openpaperwork/pyinsane"
+SRC_URI="https://github.com/openpaperwork/pyinsane/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+
+ # Upstream Makefile requires git checkout
+ echo "version = \"${PV}\"" > pyinsane2/_version.py || die
+}