summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1-r1.ebuild92
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1-r3.ebuild (renamed from dev-libs/tntnet/tntnet-2.2.1-r2.ebuild)7
2 files changed, 6 insertions, 93 deletions
diff --git a/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild b/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
deleted file mode 100644
index 617f01ca9a91..000000000000
--- a/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="Modular, multithreaded web application server extensible with C++"
-HOMEPAGE="http://www.tntnet.org/"
-SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="doc gnutls libressl server ssl examples"
-
-RDEPEND=">=dev-libs/cxxtools-2.2.1
- sys-libs/zlib[minizip]
- ssl? (
- gnutls? (
- >=net-libs/gnutls-1.2.0
- dev-libs/libgcrypt:0
- )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- app-arch/zip"
-
-src_prepare() {
- # Both fixed in the next release
- epatch "${FILESDIR}"/${PN}-2.0-zlib-minizip.patch
- rm framework/common/{ioapi,unzip}.[ch] || die
-
- # bug 423697
- sed -e "s:unzip.h:minizip/unzip.h:" -i framework/defcomp/unzipcomp.cpp
-
- eautoreconf
-
- sed -i -e 's:@localstatedir@:/var:' etc/tntnet/tntnet.xml.in || die
-}
-
-src_configure() {
- local myconf=""
-
- # Prefer gnutls above SSL
- if use gnutls; then
- einfo "Using gnutls for ssl support."
- myconf="${myconf} --with-ssl=gnutls"
- elif use ssl; then
- einfo "Using openssl for ssl support."
- myconf="${myconf} --with-ssl=openssl"
- else
- myconf="${myconf} --with-ssl=no"
- fi
-
- # default enabled, will not compile without sdk
- myconf="${myconf} --with-sdk"
-
- econf \
- $(use_with server) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog README TODO
- if use doc; then
- dodoc doc/*.pdf
- fi
-
- if use examples; then
- cd "${S}/sdk/demos"
- emake clean
- rm -rf .deps */.deps .libs */.libs
- cd "${S}"
-
- insinto /usr/share/doc/${PF}/examples
- doins -r sdk/demos/*
- fi
-
- if use server; then
- rm -f "${D}/etc/init.d/tntnet"
- newinitd "${FILESDIR}/tntnet.initd" tntnet
- fi
-}
-
-# @stable ~26may2020 \ No newline at end of file
diff --git a/dev-libs/tntnet/tntnet-2.2.1-r2.ebuild b/dev-libs/tntnet/tntnet-2.2.1-r3.ebuild
index 2a1e7bb6230c..8f1ea542f980 100644
--- a/dev-libs/tntnet/tntnet-2.2.1-r2.ebuild
+++ b/dev-libs/tntnet/tntnet-2.2.1-r3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="gnutls libressl server ssl examples"
+IUSE="gnutls libressl server ssl examples static-libs"
RDEPEND=">=dev-libs/cxxtools-2.2.1
sys-libs/zlib[minizip]
@@ -91,4 +91,9 @@ src_install() {
rm -f "${D}/etc/init.d/tntnet"
newinitd "${FILESDIR}/tntnet.initd" tntnet
fi
+
+ # bug 737184
+ if ! use static-libs; then
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+ fi
}