summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/mars/mars-1.2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sci-chemistry/mars/mars-1.2.ebuild b/sci-chemistry/mars/mars-1.2.ebuild
index 5fd849dc4cb1..58667bc6dd8e 100644
--- a/sci-chemistry/mars/mars-1.2.ebuild
+++ b/sci-chemistry/mars/mars-1.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
MY_P="${P}_linux"
@@ -9,17 +9,15 @@ DESCRIPTION="Robust automatic backbone assignment of proteins"
HOMEPAGE="http://www.mpibpc.mpg.de/groups/zweckstetter/_links/software_mars.htm"
SRC_URI="http://www.mpibpc.mpg.de/groups/zweckstetter/_software_files/_${PN}/${MY_P}.tar.gz"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="all-rights-reserved"
IUSE="examples"
+RESTRICT=mirror
RDEPEND="sci-biology/psipred"
-DEPEND=""
-RESTRICT=mirror
-
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
QA_PREBUILT="opt/mars/*"
@@ -28,15 +26,17 @@ src_install() {
exeinto /opt/${PN}/
doexe bin/{${PN},calcJC-S2,runmars*,*.awk} *.awk
+
insinto /opt/${PN}/
doins bin/*.{tab,txt}
+
if use examples; then
insinto /usr/share/${PN}/
doins -r examples
fi
- cat >> "${T}"/23mars <<- EOF
- MARSHOME="${EPREFIX}/opt/${PN}"
+ cat >> "${T}"/23mars <<- EOF || die
+ MARSHOME="${EPREFIX}/opt/${PN}"
EOF
doenvd "${T}"/23mars