summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.0.ebuild41
-rw-r--r--x11-misc/compose-tables/metadata.xml11
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
new file mode 100644
index 000000000000..e3fb1475398a
--- /dev/null
+++ b/x11-misc/compose-tables/Manifest
@@ -0,0 +1 @@
+DIST libX11-1.7.0.tar.bz2 2409144 BLAKE2B 1eb6aa8f2fe50ddb2f6d324429b3d9cecfb48833c3f52f22ae8e32846be614c8db63c57d25e2b1c46612b6b333ff61ceab8ac0b605b117bcea1224f918af8e6d SHA512 f661ca90350fd8a94f054b00f12f5122cea068ebff706acfd399462236c189a296a2358d17d16166635101cf56cc19303dd407873a159932d093c9f33556f9fb
diff --git a/x11-misc/compose-tables/compose-tables-1.7.0.ebuild b/x11-misc/compose-tables/compose-tables-1.7.0.ebuild
new file mode 100644
index 000000000000..680f8d2f5248
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_STATIC=no
+XORG_MULTILIB=no
+inherit xorg-3
+
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+DESCRIPTION="X.Org Compose Key tables from libX11"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}
+
+src_test() {
+ :;
+}
diff --git a/x11-misc/compose-tables/metadata.xml b/x11-misc/compose-tables/metadata.xml
new file mode 100644
index 000000000000..e1e8e6f760c3
--- /dev/null
+++ b/x11-misc/compose-tables/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>x11@gentoo.org</email>
+ <name>X11</name>
+</maintainer>
+<upstream>
+ <remote-id type="cpe">cpe:/a:x.org:libx11</remote-id>
+</upstream>
+</pkgmetadata>