summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.19_rc8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 3149ec0f214d..fcc9ca2c49b5 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -6,3 +6,4 @@ DIST patch-4.19-rc4.patch 38932487 BLAKE2B fc07f52bc086f9d4f52e1ebd996ac1a2cdfce
DIST patch-4.19-rc5.patch 39132199 BLAKE2B 511377a23c45f3905fb710c09727a2a8ce93b7e1b10e2274dd38ee7b2095390a4f99c6e193756719b5de9fd6c17d0d901be1aef78b92718436745ece0a57b82f SHA512 0080e66cf9f0ae187c9210ecc5af15978642916d71920383e365cfcb3c837a5ee4052fd53030eafa1ccdd996663ad66d1730c8e49e85e584bc616dcf6389868e
DIST patch-4.19-rc6.patch 39335180 BLAKE2B 94bbeb07c7d0dadabdad0c177148747d04d3f1d1dc47257183113d6d54d9b59f67a80efeed8d7c8116d088065435b9c87352631cb910ac583f02688ee96f2884 SHA512 15b4748e8d98a6843c7fc47081996c79c3d4a11302ef786193432f70ec809628294dbffc5b162113aa04d2313ad69d8fafe5713a19397ce82d36e134630be59b
DIST patch-4.19-rc7.patch 39634304 BLAKE2B 98bf6c83118e7ce7f90ecd7c70412b8854a83c4ed6843021e7fc6b4340dc9bf89e29b30404c2e4ba16a3ba7c85d7d48bb00b16531de7b625a5ddf731b43c526c SHA512 cb0bc2ab8b3efe7332fb498bef706c556071e6623d76092dbbcc14d6741051bb1fe97d7c52baa0a950803c7cc186868b87b842e9fb9f61fce95befaa5be40cd0
+DIST patch-4.19-rc8.patch 39758717 BLAKE2B 56c7188f0a47b042fa92c3492feb3ff4f980508afbab17adada089ad6549c0b204b619555573221557d05b11a0b0d225a7d3f2929778e2ee66d7c73cd942a690 SHA512 b20a6aa57f6609d41a0687aad9b90bf1be04fbdc4c7312520bb3b28405142d684a7018071afd5bf8034130ce297f424c68fd93922faa0a27268c73e572213ed6
diff --git a/sys-kernel/git-sources/git-sources-4.19_rc8.ebuild b/sys-kernel/git-sources/git-sources-4.19_rc8.ebuild
new file mode 100644
index 000000000000..73fcf5fcd5c2
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.19_rc8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.18"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}