summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.4.90.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 9da862b189c6..f7966813b6ef 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1 +1,2 @@
DIST mousepad-0.4.2.tar.bz2 696014 BLAKE2B 2591f177b59147e01502329939365c5f18031f3dc9100baa29cb1da04afbff26cc91cc612ea1e5ebbc2d15754375da6afbd4ae9d96399f41cf06191d7d8d7082 SHA512 f3266018ce61683dc62b6866649f3674cc363ea652de04d3f087341c61cf24fb5eb730411948e354d085792f88b59e3dba7e7712715d92711f750b33d8bfb69a
+DIST mousepad-0.4.90.tar.bz2 808320 BLAKE2B 5a639001663d24a9d0ae126f672adb5d3a72825893e0f0d90e263596f214d76f973e0743248efee8562dc04afb09c0519ed649ca5d36b9221569490e289d687f SHA512 e839584782b09ee9d485ca4dcf05e22afb459cba269b3a15fe2dc0e3f3240bc15b1a8d7db92160b735d97d7293e67b0484b50ac3e72946b499dc65ac1097390b
diff --git a/app-editors/mousepad/mousepad-0.4.90.ebuild b/app-editors/mousepad/mousepad-0.4.90.ebuild
new file mode 100644
index 000000000000..8d5d963fcc26
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.4.90.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.45.8:2=
+ >=xfce-base/xfconf-4.12:=
+ >=x11-libs/gtk+-3.20:3=
+ x11-libs/gtksourceview:3.0="
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}