summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/atanks/Manifest1
-rw-r--r--games-action/atanks/atanks-6.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/games-action/atanks/Manifest b/games-action/atanks/Manifest
index 0654656ddcfa..cfd190f706c5 100644
--- a/games-action/atanks/Manifest
+++ b/games-action/atanks/Manifest
@@ -1 +1,2 @@
DIST atanks-6.4.tar.gz 6059315 BLAKE2B ea217b5dceaf63e85e3772369ebab1f76d35175cf8e2d0914e2806db8209f9d4721590f8a285bbfe0938f4957eec409e1581189257f117ec5d5e4c3af59707c1 SHA512 e9410e5bf0e8ec0281718ad8ddca74b67000db96b09b6af8aa906bbf2cd815f07ff550087ecdee2e4c5bfabc42941f184173f35e50538e57bb008372a599e1e6
+DIST atanks-6.5.tar.gz 6059648 BLAKE2B 8a5c3e77391d0e7b3dc8170f49e2cd24fb31eda6f29362851d29eba5dc10748d2b95bfb688771fbbdaac4aada253f06c5ce4064e293335ef59cc8accc43a64a0 SHA512 cb1456e06132da754ae5d9926e118ecb8ac7789747f0a3273bcb49311d79824610bb9cfc74fbba8c75bbefe905d63ae2e01d193ccb37a64759f5490328c8cc89
diff --git a/games-action/atanks/atanks-6.5.ebuild b/games-action/atanks/atanks-6.5.ebuild
new file mode 100644
index 000000000000..1efffe797e76
--- /dev/null
+++ b/games-action/atanks/atanks-6.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop gnome2-utils toolchain-funcs
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="https://atanks.sourceforge.io/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/allegro:0[X]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-6.4-fix-build-system.patch )
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake INSTALLDIR="${EPREFIX}/usr/share/${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ local DOCS=( Changelog README TODO )
+ einstalldocs
+
+ insinto /usr/share/${PN}
+ doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
+
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+}