summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/adwaita-qt/Manifest1
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/Manifest b/x11-themes/adwaita-qt/Manifest
index 784c2045f665..3da6bbbceeff 100644
--- a/x11-themes/adwaita-qt/Manifest
+++ b/x11-themes/adwaita-qt/Manifest
@@ -1 +1,2 @@
DIST adwaita-qt-1.0.tar.gz 565625 BLAKE2B 73dba06dd785131d8bb949b5dcb195994d415e295b196228fd6145687431a3fd4984489c81322cfd1437fa8de3a97e41b30b49bba35baa30b379e02770b52928 SHA512 35993a9f99f9d41812d448d679a9e7a8cb15e8ed9b23a2ea9a33c61c1bfc98a226f8bea2fce3ff0dab29420ff10c4e4a4a800c9b989475cc66c4042257fe154c
+DIST adwaita-qt-1.1.0.tar.gz 435576 BLAKE2B e85e918e2527cc26f7804f1b03e75163b8c30d46402e3de3dca7afb93ac7abd81fe5e10b4d858859cf9abf443ec57cf74cc1ab578a45798dcb73d4b17da08cc5 SHA512 5203b64cb9e4038579c68ae8f52bc8c2fcdaf0ab46ce134f2a92b318493cc69718ce4d69968f1da20fcdf5f5492c38a6a225475f74f75390ada1337d35504a01
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
new file mode 100644
index 000000000000..5e4cc7643b77
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="gnome"
+
+RDEPEND="
+ gnome? ( x11-themes/QGnomePlatform )
+ dev-qt/qtwidgets:5
+ dev-qt/qtdbus:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BUILD_DIR="${WORKDIR}/${PN}_qt5"
+ local mycmakeargs=( -DUSE_QT4=OFF )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_compile -C "${_d}"
+ done
+}
+
+src_install() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_install -C "${_d}"
+ done
+}