summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/c-intercal/c-intercal-31.0.ebuild3
-rw-r--r--dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-lang/c-intercal/c-intercal-31.0.ebuild b/dev-lang/c-intercal/c-intercal-31.0.ebuild
index fa55b57e11b6..5f04f53c129f 100644
--- a/dev-lang/c-intercal/c-intercal-31.0.ebuild
+++ b/dev-lang/c-intercal/c-intercal-31.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,7 @@ SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}"/${P}-version.patch
+ eapply "${FILESDIR}"/${P}-no-common.patch
eapply_user
eautoreconf
}
diff --git a/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
new file mode 100644
index 000000000000..ff409aeb2518
--- /dev/null
+++ b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/711902
+
+--- intercal-0.31-orig/src/perpet.c
++++ intercal-0.31/src/perpet.c
+@@ -85,7 +85,7 @@
+ /* function created by yacc */
+ extern int yyparse(void);
+
+-int yydebug;
++extern int yydebug;
+
+ /* compilation options */
+ bool compile_only; /* just compile into C, don't run the linker */