summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-fonts/zh-kcfonts/Manifest2
-rw-r--r--media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch4
-rw-r--r--media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild42
3 files changed, 23 insertions, 25 deletions
diff --git a/media-fonts/zh-kcfonts/Manifest b/media-fonts/zh-kcfonts/Manifest
index 67b3af95bcd5..97fdd862b475 100644
--- a/media-fonts/zh-kcfonts/Manifest
+++ b/media-fonts/zh-kcfonts/Manifest
@@ -1,2 +1,2 @@
-DIST kcfonts-1.05-freebsd-aa_ad.patch.gz 4825 BLAKE2B 681e23308fe202d6f3276ffc0a61186d623bafb95a7af66949ee2df52ac76632dfd65247b98e0f6ee639f19e098fd86a205e2b96a705982697db7f68a3bedfd7 SHA512 31146c530e5f3845b184029e22c71b7ee8fa1fd73e0fdf3e6cf90500129e70a58738d75926c97c71467571899f8a1f2f71df5a15fb68a503a5f06a4354ea42f6
DIST kcfonts-1.05.tar.gz 903701 BLAKE2B 344017187fb5ff1a13cb9e05e84a56d38a7b7d14865ec471bf9c36c383f1681b1944346af2d3b1f67ba340b8101a968ef527f0a27ee7e5ac3837f1c67da33325 SHA512 a8b94e8f8095a8578ff340637bf4a197db56948d0d7ecda0d4f17da51bafc09080761f32894f88a54c88945f72b10a11dcb04e5841c19c4eb6852e263fb64209
+DIST zh-kcfonts-1.05-freebsd-aa_ad.patch.gz 4749 BLAKE2B 3d488977e76ae71587ced990816a85173b5a3196df3803ba517d99b8ad4244d59355a0b9c34d683c7cdf8b5660a0f411c9d544379caf0ddca1f8bef35eb7028b SHA512 2881c31ffc5b8fbc2e27edd6f139436da89bd3db3a654bbcb4b8f037db0388bf592b83014b750057264694040c8f2c3d28718f46ad3cf1fe5e13256df7666fae
diff --git a/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch b/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
index 93fc8ed9608e..46d552b3a63e 100644
--- a/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
+++ b/media-fonts/zh-kcfonts/files/kcfonts-1.05-parallel-make.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2009-01-01 10:45:14.000000000 +0900
-+++ Makefile 2009-01-01 10:45:32.000000000 +0900
+--- a/Makefile
++++ b/Makefile
@@ -31,7 +31,7 @@
$(CC) $(CFLAGS) tran.o kc24f.o -o $@
kc15f: tran.o kc15f.o
diff --git a/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
index fcc568527812..c08fdae5871d 100644
--- a/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
+++ b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
@@ -1,42 +1,40 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-S="${WORKDIR}"
-inherit eutils font toolchain-funcs
+inherit font toolchain-funcs
+
+MY_P="${P#zh-}"
-MY_P="kcfonts-${PV}"
DESCRIPTION="Kuo Chauo Chinese Fonts collection in BIG5 encoding"
-SRC_URI="ftp://freebsd.sinica.edu.tw/pub/distfiles/${MY_P}.tar.gz
- ftp://wm28.csie.ncu.edu.tw/pub/distfiles/${MY_P}.tar.gz
- mirror://gentoo/${MY_P}-freebsd-aa_ad.patch.gz"
-HOMEPAGE="http://freebsd.sinica.edu.tw/"
# no real homepage exists, but this was written by Taiwanese FreeBSD devs
+HOMEPAGE="http://freebsd.sinica.edu.tw/"
+SRC_URI="
+ ftp://freebsd.sinica.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ ftp://wm28.csie.ncu.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${P}-freebsd-aa_ad.patch.gz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86"
IUSE=""
-
# Only installs fonts
RESTRICT="strip binchecks"
-DEPEND="x11-apps/bdftopcf"
-RDEPEND=""
+BDEPEND="x11-apps/bdftopcf"
-FONT_SUFFIX="pcf.gz"
-DOCS="00README Xdefaults.*"
+S="${WORKDIR}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+PATCHES=(
+ "${WORKDIR}"/${P}-freebsd-aa_ad.patch
+ "${FILESDIR}"/${MY_P}-code-fixups.patch
+ "${FILESDIR}"/${MY_P}-parallel-make.patch
+)
- epatch "${WORKDIR}/${MY_P}-freebsd-aa_ad.patch"
- epatch "${FILESDIR}/${MY_P}-code-fixups.patch"
- epatch "${FILESDIR}/${MY_P}-parallel-make.patch"
-}
+FONT_SUFFIX="pcf.gz"
+DOCS="00README Xdefaults.*"
src_compile() {
- emake CC="$(tc-getCC)" || die
+ emake CC="$(tc-getCC)"
}