summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.21.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 8a04845c7ac8..1d2b179c45d1 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest-httpx-0.20.0.gh.tar.gz 23106 BLAKE2B b44890bc0f916a10d57b1fe16523808cc9ab9a364d39980c49b4d26823afe7c9388b442cf99225605d741d192b5f282acdce0c7929e00ea076f10f04a55597a3 SHA512 54f588ddaaa0b9909f38a25ae1cf08d63f943a0fa169d4b77d2e8b967fc001af1f667b7c91dfcaf14bbed948d72df22ec133468ad692157b31259b2b155ebd88
+DIST pytest-httpx-0.21.0.gh.tar.gz 23123 BLAKE2B a9a1bc9effc557829071f13cec76aa1d164ae7040b685390c92f33c644c804448eba1ad3e841abdb667a2c0289abd64f5d3633779bd8b0355a1c03d390d94bd5 SHA512 6be6fb39ad1ef233ce9be7cf510422754b6c97a1b565d49224e82cbe4218ee24051b6c5865215ed575f200446dfe8dd1470908467c67077c51a4f5412b113c2a
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.21.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.21.0.ebuild
new file mode 100644
index 000000000000..779e7bf2b179
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.21.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.23*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest