summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-visualization/gnuplot/Manifest1
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.2.2.ebuild211
2 files changed, 212 insertions, 0 deletions
diff --git a/sci-visualization/gnuplot/Manifest b/sci-visualization/gnuplot/Manifest
index 3bfda9dd7788..93baef6850ea 100644
--- a/sci-visualization/gnuplot/Manifest
+++ b/sci-visualization/gnuplot/Manifest
@@ -2,3 +2,4 @@ DIST gnuplot-5.0.1.tar.gz 4963747 SHA256 7cbc557e71df581ea520123fb439dea5f073adc
DIST gnuplot-5.0.5.tar.gz 5078771 SHA256 25f3e0bf192e01115c580f278c3725d7a569eb848786e12b455a3fda70312053 SHA512 fd6efc3a869850fa1939a4c833c776395efaaaf6dccc63e3626cee2e39938923b06314368802155adf711ae3e5ca0e3dd1a88be348e8571f9d0be8790240c62c WHIRLPOOL 586aa59439d92c1a05169b57b1c7369465914870788b20b394fef0591a84f134ce6f6707b370105f55277d326d3ab578904ac82355c8d97b7337a7980ab8e29e
DIST gnuplot-5.0.6.tar.gz 5093897 SHA256 5bbe4713e555c2e103b7d4ffd45fca69551fff09cf5c3f9cb17428aaacc9b460 SHA512 7f9b05725a8594dcfbf1f1fc8f1db9bf45e1b6841fa1089b2c2528a3e36f71baab16d5fbeb027e4dd3618461a4895d037cb9f43781bfee2cb078cb9583567d8d WHIRLPOOL 3f3cf31f764af36d3761a17447ed8da98aec1148270eacc33c48605cf0dbff6dbde4b726403d4177da2104e6ff9baa4d48e0e3c65630a057ab1dc01f641daf5e
DIST gnuplot-5.0.7.tar.gz 5100186 SHA256 0ad760ff013b4a9cf29853fa9b50c50030a33cd8fb86220a23abb466655136fc SHA512 5d7241dc1472f87af8632110a1e88f83b5ea3f41e1bc8c89a45dc4662a3071d91a25bf9ae5196a2b8bef09c8079c22f635bb947c02def3416d78880d61eea919 WHIRLPOOL f8382c7a0e9a460f6898eaa4c280db9d6088aa997c2685350c23d97b2ec09b14236f6caa057b41f7f02a513734a99a18da3383e9ed769e821204de14a11d35cf
+DIST gnuplot-5.2.2.tar.gz 5282973 SHA256 a416d22f02bdf3873ef82c5eb7f8e94146795811ef808e12b035ada88ef7b1a1 SHA512 51d5b2234dae358580cc2794ed63f8a5b950baf73edc5362f5bb18d77e8066c3c010239c3b29840db11e5936cb9381bb57193de751bd274af5547a45d6d88b0b WHIRLPOOL b8d81ae768946db0fbc5418d11291b491dd3968777e7a684df33efa7070638fdc4d918617043e465dbddbd2bc24da73a07f45a3c290e44d4356519f0658ec9ee
diff --git a/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild b/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild
new file mode 100644
index 000000000000..2b8515bf041c
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic readme.gentoo-r1 toolchain-funcs wxwidgets
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+
+if [[ -z ${PV%%*9999} ]]; then
+ inherit cvs
+ ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot"
+ ECVS_MODULE="gnuplot"
+ ECVS_BRANCH="HEAD"
+ ECVS_USER="anonymous"
+ ECVS_CVS_OPTIONS="-dP"
+ MY_P="${PN}"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ MY_P="${P/_/.}"
+ SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="gnuplot bitmap? ( free-noncomm )"
+SLOT="0"
+IUSE="aqua bitmap cairo compat doc examples +gd ggi latex libcaca libcerf lua qt5 readline svga wxwidgets X"
+
+RDEPEND="
+ cairo? (
+ x11-libs/cairo
+ x11-libs/pango )
+ gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
+ ggi? ( media-libs/libggi )
+ latex? (
+ virtual/latex-base
+ lua? (
+ dev-tex/pgf
+ >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
+ libcaca? ( media-libs/libcaca )
+ lua? ( dev-lang/lua:0 )
+ qt5? ( dev-qt/qtcore:5=
+ dev-qt/qtgui:5=
+ dev-qt/qtnetwork:5=
+ dev-qt/qtprintsupport:5=
+ dev-qt/qtsvg:5=
+ dev-qt/qtwidgets:5= )
+ readline? ( sys-libs/readline:0= )
+ libcerf? ( sci-libs/libcerf )
+ svga? ( media-libs/svgalib )
+ wxwidgets? (
+ x11-libs/wxGTK:3.0[X]
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gtk+:2 )
+ X? ( x11-libs/libXaw )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ app-text/ghostscript-gpl )"
+
+S="${WORKDIR}/${MY_P}"
+
+GP_VERSION="${PV%.*}"
+E_SITEFILE="lisp/50${PN}-gentoo.el"
+TEXMF="${EPREFIX}/usr/share/texmf-site"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
+ eapply "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
+ eapply_user
+
+ if [[ -z ${PV%%*9999} ]]; then
+ local dir
+ for dir in config demo m4 term tutorial; do
+ emake -C "$dir" -f Makefile.am.in Makefile.am
+ done
+ fi
+
+ # Add special version identification as required by provision 2
+ # of the gnuplot license
+ sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+ DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
+ for details. You can use the "pdfcairo" terminal for PDF output.'
+ use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+ use svga && DOC_CONTENTS+='\n\nIn order to enable ordinary users to use
+ SVGA console graphics, gnuplot needs to be set up as setuid root.
+ Please note that this is usually considered to be a security hazard.
+ As root, manually "chmod u+s /usr/bin/gnuplot".'
+ use gd && DOC_CONTENTS+='\n\nFor font support in png/jpeg/gif output,
+ you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+ environment variables. See the FAQ file in /usr/share/doc/${PF}/
+ for more information.'
+
+ eautoreconf
+
+ # Make sure we don't mix build & host flags.
+ sed -i \
+ -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
+ -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
+ -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
+ -e 's:@CC@:$(CC_FOR_BUILD):' \
+ docs/Makefile.in || die
+}
+
+src_configure() {
+ if ! use latex; then
+ sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
+ fi
+
+ if use wxwidgets; then
+ WX_GTK_VER="3.0"
+ need-wxwidgets unicode
+ fi
+
+ tc-export CC CXX #453174
+ tc-export_build_env BUILD_CC
+ export CC_FOR_BUILD=${BUILD_CC}
+
+ use qt5 && append-cxxflags -std=c++11
+
+ econf \
+ --with-texdir="${TEXMF}/tex/latex/${PN}" \
+ --with-readline=$(usex readline gnu builtin) \
+ $(use_with bitmap bitmap-terminals) \
+ $(use_with cairo) \
+ $(use_enable compat backwards-compatibility) \
+ $(use_with doc tutorial) \
+ $(use_with gd) \
+ "$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
+ "$(use_with ggi xmi "${EPREFIX}/usr/$(get_libdir)")" \
+ "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with libcerf) \
+ $(use_with lua) \
+ $(use_with svga linux-vga) \
+ $(use_with X x) \
+ --enable-stats \
+ $(use_with qt5 qt qt5) \
+ $(use_enable wxwidgets) \
+ DIST_CONTACT="https://bugs.gentoo.org/" \
+ EMACS=no
+}
+
+src_compile() {
+ # Prevent access violations, see bug 201871
+ export VARTEXFONTS="${T}/fonts"
+
+ # We believe that the following line is no longer needed.
+ # In case of problems file a bug report at bugs.gentoo.org.
+ #addwrite /dev/svga:/dev/mouse:/dev/tts/0
+
+ emake all
+
+ if use doc; then
+ # Avoid sandbox violation in epstopdf/ghostscript
+ addpredict /var/cache/fontconfig
+ if use cairo; then
+ emake -C docs pdf
+ else
+ ewarn "Cannot build figures unless cairo is enabled."
+ ewarn "Building documentation without figures."
+ emake -C docs pdf_nofig
+ mv docs/nofigures.pdf docs/gnuplot.pdf || die
+ fi
+ emake -C tutorial pdf
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ dodoc BUGS ChangeLog NEWS PGPKEYS README* RELEASE_NOTES TODO
+ newdoc term/PostScript/README README-ps
+ newdoc term/js/README README-js
+ use lua && newdoc term/lua/README README-lua
+ readme.gentoo_create_doc
+
+ if use examples; then
+ # Demo files
+ insinto /usr/share/${PN}/${GP_VERSION}
+ doins -r demo
+ rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
+ rm -f "${ED%/}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
+ fi
+
+ if use doc; then
+ # Manual, tutorial, FAQ
+ dodoc docs/gnuplot.pdf tutorial/{tutorial.dvi,tutorial.pdf} FAQ.pdf
+ # Documentation for making PostScript files
+ docinto psdoc
+ dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+}
+
+src_test() {
+ GNUTERM="unknown" default_src_test
+}
+
+pkg_postinst() {
+ use latex && texmf-update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ use latex && texmf-update
+}