summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/radicale/Manifest1
-rw-r--r--www-apps/radicale/radicale-2.1.10-r1.ebuild82
-rw-r--r--www-apps/radicale/radicale-2.1.10.ebuild84
-rw-r--r--www-apps/radicale/radicale-2.1.11.ebuild82
-rw-r--r--www-apps/radicale/radicale-2.1.8.ebuild83
5 files changed, 0 insertions, 332 deletions
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
index 38d3d8bb9f31..e1016129c11a 100644
--- a/www-apps/radicale/Manifest
+++ b/www-apps/radicale/Manifest
@@ -1,4 +1,3 @@
DIST Radicale-1.1.6.tar.gz 48280 BLAKE2B 38d3047d473fad24188b597a57d3e1f0e34df03f00f6806b86c447ed731be074bf0b5f6dfb951c8a9f627993bf0763792150bc06532414a658e4d306123fcdd6 SHA512 3fed85fc5fa2b041277112870b8b508a22cc85ec0680dd1cf9411e73715e18a9b0ddd651eafb0c9529bd308e7fd87ae44ecdd82935f4062050919780301d56d9
DIST Radicale-2.1.10.tar.gz 77790 BLAKE2B 37061dd049dc918775f20b522ed86a47f32f34505c13763f8ae49ff007aca77f88caafc959be857c735c11b13506efdfc8413750808b88d5ea6dbe69e05f03ff SHA512 30fac6639e56bbd10664330d84ebba28b34005b4b4b4c5a6c22f53cb7e810ba4961cbd314e62fe33538674a2d4b45f14751f36ef5fa2ae2b7d44c1b1158f6e1c
DIST Radicale-2.1.11.tar.gz 76490 BLAKE2B 35578b693a32d4a77f8ff1c93cbb8fb63fd8dabf9fde79cd928d4afa6e059fe836840ca6a33621c13e9421a69bfb25cbb59688ba83bed62003ef3b56b54804b1 SHA512 e85f12664d3db6b911dd534eaddd15c498ca4f641cc15523644300aca8b1ef3f6fd4d9645857235502f03a7903111905537b04f9a6fdbde1a60fbb720d377733
-DIST Radicale-2.1.8.tar.gz 76348 BLAKE2B 87a4ec20990dc7e5dbba88a3fb3d1475210d40c12584d5bb7ba7c6d1ca2cd8efb97b7054d322f0a7fbe58fd8325be63df52f1d370cc13ccc90863b0900925656 SHA512 038bee4114b090bcf873e8a4ec83cbbc7bdd34b4843fd1a769a023c891b589b3a18637d5f8f8595691a7930804ad7695e333bb9df96d00515b7a3695294eb5f7
diff --git a/www-apps/radicale/radicale-2.1.10-r1.ebuild b/www-apps/radicale/radicale-2.1.10-r1.ebuild
deleted file mode 100644
index 34fd1a1d2f88..000000000000
--- a/www-apps/radicale/radicale-2.1.10-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-
-inherit distutils-r1 eutils user
-
-MY_PN="Radicale"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A simple CalDAV calendar server"
-HOMEPAGE="https://radicale.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bcrypt"
-
-RDEPEND="sys-apps/util-linux
- >=dev-python/vobject-0.9.6[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]
- bcrypt? ( dev-python/passlib[bcrypt,${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-RDIR=/var/lib/radicale
-
-pkg_pretend() {
- if [[ -f ${RDIR}/.props && ${MERGE_TYPE} != buildonly ]]; then
- eerror "It looks like you have a version 1 database in ${RDIR}."
- eerror "You must convert this database to version 2 format before upgrading."
- eerror "You may want to back up the old database before migrating."
- eerror
- eerror "If you have kept the Gentoo-default database configuration, this will work:"
- eerror "1. Stop any running instance of Radicale."
- eerror "2. Run \`radicale --export-storage ~/radicale-exported\`."
- eerror "3. Run \`chown -R radicale: ~/radicale-exported\`"
- eerror "4. Run \`mv \"${RDIR}\" \"${RDIR}.old\"\`."
- eerror "5. Install Radicale version 2."
- eerror "6. Run \`mv ~/radicale-exported \"${RDIR}/collections\"\`."
- eerror
- eerror "For more details, or if you are have a more complex configuration,"
- eerror "please see the migration guide: https://radicale.org/1to2/"
- eerror "If you do a custom migration, please ensure the database is cleaned out of"
- eerror "${RDIR}, including the hidden .props file."
- die
- fi
-}
-
-pkg_setup() {
- enewgroup radicale
- enewuser radicale -1 -1 ${RDIR} radicale
-}
-
-python_install_all() {
- rm README* || die
-
- # init file
- newinitd "${FILESDIR}"/radicale-r1.init.d radicale
-
- # directories
- diropts -m0750 -oradicale -gradicale
- keepdir ${RDIR}
-
- # config file
- insinto /etc/${PN}
- doins config logging
-
- # fcgi and wsgi files
- exeinto /usr/share/${PN}
- doexe radicale.fcgi radicale.wsgi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo "A sample WSGI script has been put into ${ROOT%/}/usr/share/${PN}."
- einfo "You will also find there an example FastCGI script."
-}
diff --git a/www-apps/radicale/radicale-2.1.10.ebuild b/www-apps/radicale/radicale-2.1.10.ebuild
deleted file mode 100644
index 89f03ec7fc82..000000000000
--- a/www-apps/radicale/radicale-2.1.10.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-
-inherit distutils-r1 eutils user
-
-MY_PN="Radicale"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A simple CalDAV calendar server"
-HOMEPAGE="https://radicale.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bcrypt"
-
-RDEPEND=">=dev-python/vobject-0.9.6[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]
- bcrypt? ( dev-python/passlib[bcrypt,${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-RDIR=/var/lib/radicale
-LDIR=/var/log/radicale
-
-pkg_pretend() {
- if [[ -f ${RDIR}/.props && ${MERGE_TYPE} != buildonly ]]; then
- eerror "It looks like you have a version 1 database in ${RDIR}."
- eerror "You must convert this database to version 2 format before upgrading."
- eerror "You may want to back up the old database before migrating."
- eerror
- eerror "If you have kept the Gentoo-default database configuration, this will work:"
- eerror "1. Stop any running instance of Radicale."
- eerror "2. Run \`radicale --export-storage ~/radicale-exported\`."
- eerror "3. Run \`chown -R radicale: ~/radicale-exported\`"
- eerror "4. Run \`mv \"${RDIR}\" \"${RDIR}.old\"\`."
- eerror "5. Install Radicale version 2."
- eerror "6. Run \`mv ~/radicale-exported \"${RDIR}/collections\"\`."
- eerror
- eerror "For more details, or if you are have a more complex configuration,"
- eerror "please see the migration guide: https://radicale.org/1to2/"
- eerror "If you do a custom migration, please ensure the database is cleaned out of"
- eerror "${RDIR}, including the hidden .props file."
- die
- fi
-}
-
-pkg_setup() {
- enewgroup radicale
- enewuser radicale -1 -1 ${RDIR} radicale
-}
-
-python_install_all() {
- rm README* || die
-
- # init file
- newinitd "${FILESDIR}"/radicale.init.d radicale
-
- # directories
- diropts -m0750 -oradicale -gradicale
- keepdir ${RDIR}
- diropts -m0755 -oradicale -gradicale
- keepdir ${LDIR}
-
- # config file
- insinto /etc/${PN}
- doins config logging
-
- # fcgi and wsgi files
- exeinto /usr/share/${PN}
- doexe radicale.fcgi radicale.wsgi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo "A sample WSGI script has been put into ${ROOT%/}/usr/share/${PN}."
- einfo "You will also find there an example FastCGI script."
-}
diff --git a/www-apps/radicale/radicale-2.1.11.ebuild b/www-apps/radicale/radicale-2.1.11.ebuild
deleted file mode 100644
index a65d7bc588b7..000000000000
--- a/www-apps/radicale/radicale-2.1.11.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-
-inherit distutils-r1 eutils user
-
-MY_PN="Radicale"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A simple CalDAV calendar server"
-HOMEPAGE="https://radicale.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bcrypt"
-
-RDEPEND="sys-apps/util-linux
- >=dev-python/vobject-0.9.6[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]
- bcrypt? ( dev-python/passlib[bcrypt,${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-RDIR=/var/lib/radicale
-
-pkg_pretend() {
- if [[ -f ${RDIR}/.props && ${MERGE_TYPE} != buildonly ]]; then
- eerror "It looks like you have a version 1 database in ${RDIR}."
- eerror "You must convert this database to version 2 format before upgrading."
- eerror "You may want to back up the old database before migrating."
- eerror
- eerror "If you have kept the Gentoo-default database configuration, this will work:"
- eerror "1. Stop any running instance of Radicale."
- eerror "2. Run \`radicale --export-storage ~/radicale-exported\`."
- eerror "3. Run \`chown -R radicale: ~/radicale-exported\`"
- eerror "4. Run \`mv \"${RDIR}\" \"${RDIR}.old\"\`."
- eerror "5. Install Radicale version 2."
- eerror "6. Run \`mv ~/radicale-exported \"${RDIR}/collections\"\`."
- eerror
- eerror "For more details, or if you are have a more complex configuration,"
- eerror "please see the migration guide: https://radicale.org/1to2/"
- eerror "If you do a custom migration, please ensure the database is cleaned out of"
- eerror "${RDIR}, including the hidden .props file."
- die
- fi
-}
-
-pkg_setup() {
- enewgroup radicale
- enewuser radicale -1 -1 ${RDIR} radicale
-}
-
-python_install_all() {
- rm README* || die
-
- # init file
- newinitd "${FILESDIR}"/radicale-r1.init.d radicale
-
- # directories
- diropts -m0750 -oradicale -gradicale
- keepdir ${RDIR}
-
- # config file
- insinto /etc/${PN}
- doins config logging
-
- # fcgi and wsgi files
- exeinto /usr/share/${PN}
- doexe radicale.fcgi radicale.wsgi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo "A sample WSGI script has been put into ${ROOT%/}/usr/share/${PN}."
- einfo "You will also find there an example FastCGI script."
-}
diff --git a/www-apps/radicale/radicale-2.1.8.ebuild b/www-apps/radicale/radicale-2.1.8.ebuild
deleted file mode 100644
index 5184bfacbcf7..000000000000
--- a/www-apps/radicale/radicale-2.1.8.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-
-inherit distutils-r1 eutils user
-
-MY_PN="Radicale"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A simple CalDAV calendar server"
-HOMEPAGE="https://radicale.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+bcrypt"
-
-RDEPEND=">=dev-python/vobject-0.9.5[${PYTHON_USEDEP}]
- bcrypt? ( dev-python/passlib[bcrypt,${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-RDIR=/var/lib/radicale
-LDIR=/var/log/radicale
-
-pkg_pretend() {
- if [[ -f ${RDIR}/.props && ${MERGE_TYPE} != buildonly ]]; then
- eerror "It looks like you have a version 1 database in ${RDIR}."
- eerror "You must convert this database to version 2 format before upgrading."
- eerror "You may want to back up the old database before migrating."
- eerror
- eerror "If you have kept the Gentoo-default database configuration, this will work:"
- eerror "1. Stop any running instance of Radicale."
- eerror "2. Run \`radicale --export-storage ~/radicale-exported\`."
- eerror "3. Run \`chown -R radicale: ~/radicale-exported\`"
- eerror "4. Run \`mv \"${RDIR}\" \"${RDIR}.old\"\`."
- eerror "5. Install Radicale version 2."
- eerror "6. Run \`mv ~/radicale-exported \"${RDIR}/collections\"\`."
- eerror
- eerror "For more details, or if you are have a more complex configuration,"
- eerror "please see the migration guide: https://radicale.org/1to2/"
- eerror "If you do a custom migration, please ensure the database is cleaned out of"
- eerror "${RDIR}, including the hidden .props file."
- die
- fi
-}
-
-pkg_setup() {
- enewgroup radicale
- enewuser radicale -1 -1 ${RDIR} radicale
-}
-
-python_install_all() {
- rm README* || die
-
- # init file
- newinitd "${FILESDIR}"/radicale.init.d radicale
-
- # directories
- diropts -m0750 -oradicale -gradicale
- keepdir ${RDIR}
- diropts -m0755 -oradicale -gradicale
- keepdir ${LDIR}
-
- # config file
- insinto /etc/${PN}
- doins config logging
-
- # fcgi and wsgi files
- exeinto /usr/share/${PN}
- doexe radicale.fcgi radicale.wsgi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- einfo "A sample WSGI script has been put into ${ROOT%/}/usr/share/${PN}."
- einfo "You will also find there an example FastCGI script."
-}