summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-mta/exim/exim-4.94.2-r11.ebuild (renamed from mail-mta/exim/exim-4.94.2-r10.ebuild)0
-rw-r--r--mail-mta/exim/files/exim-4.94-CVE-2022-3559.patch4
2 files changed, 3 insertions, 1 deletions
diff --git a/mail-mta/exim/exim-4.94.2-r10.ebuild b/mail-mta/exim/exim-4.94.2-r11.ebuild
index c62c296b2534..c62c296b2534 100644
--- a/mail-mta/exim/exim-4.94.2-r10.ebuild
+++ b/mail-mta/exim/exim-4.94.2-r11.ebuild
diff --git a/mail-mta/exim/files/exim-4.94-CVE-2022-3559.patch b/mail-mta/exim/files/exim-4.94-CVE-2022-3559.patch
index 8793514b8fb7..533aaf1f9e51 100644
--- a/mail-mta/exim/files/exim-4.94-CVE-2022-3559.patch
+++ b/mail-mta/exim/files/exim-4.94-CVE-2022-3559.patch
@@ -69,7 +69,7 @@ Subject: [PATCH 1/1] Fix $regex<n> use-after-free. Bug 2915
/* precompile our regexes */
if (!(re_list_head = compile(*listptr)))
-@@ -213,3 +205,12 @@
+@@ -213,3 +205,14 @@
}
#endif /* WITH_CONTENT_SCAN */
@@ -78,7 +78,9 @@ Subject: [PATCH 1/1] Fix $regex<n> use-after-free. Bug 2915
+void
+regex_vars_clear(void)
+{
++#ifdef WITH_CONTENT_SCAN
+regex_match_string = NULL;
++#endif
+for (int i = 0; i < REGEX_VARS; i++) regex_vars[i] = NULL;
+}
+