summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/rosdiagnostic/Manifest1
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/Manifest b/dev-ros/rosdiagnostic/Manifest
index 226fda9aecc5..152341446e6c 100644
--- a/dev-ros/rosdiagnostic/Manifest
+++ b/dev-ros/rosdiagnostic/Manifest
@@ -1,2 +1,3 @@
DIST diagnostics-1.9.0.tar.gz 528593 BLAKE2B 12ecbbf0b0d091d5325c30de5ff836d245294beac7cc23976e403eee4ab6b71afd0972dded5276e96387fbc4bd2c1e57c17efff9e4c606cf18b6095f95099ba0 SHA512 98086feb84939108a959b36a3f59a7c52b4413ceb57d5c3c393db98dfad4c5f1572f584248293502a27619db706a585ebe0cb98c4af0b8681d6d78be0e1c022c
DIST diagnostics-1.9.2.tar.gz 530844 BLAKE2B 9b67f24df11ec5a716bd80ae7eb0f80f777c3014c4c0ed115e15f67649245bb685c13502a8e7889fe02bdcce43d465c11c0b2d448b698716aebed25c23512883 SHA512 6074b7fb6366bc40252af6317b27f509ee969f30c532fae47bba506f4851656d8bef041bea6256046325316807ba4d9e570f695d517b562970ecaf72d2def759
+DIST diagnostics-1.9.3.tar.gz 531618 BLAKE2B 10bbf697477d58cfe405e6634259af4125792be873bc38aa899d09089c4162a2107d5910bcba670edb5df77d5692b9c57070a4eca911c648c7a4a25d2ffa9f07 SHA512 56e97ea5751c82acc18e7098d0449c7be271c91a191d363671ff118bedb9797d0b5568394c929d534d73560ff9048915d0693aa0b66942761fb12ed255f6f1b7
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild
new file mode 100644
index 000000000000..f7437b193856
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"