summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/f3/Manifest2
-rw-r--r--sys-block/f3/f3-7.0.ebuild68
-rw-r--r--sys-block/f3/f3-7.1.ebuild66
3 files changed, 0 insertions, 136 deletions
diff --git a/sys-block/f3/Manifest b/sys-block/f3/Manifest
index a8535e7de587..456beb10b9b9 100644
--- a/sys-block/f3/Manifest
+++ b/sys-block/f3/Manifest
@@ -1,3 +1 @@
-DIST f3-7.0.tar.gz 67492 BLAKE2B 6b6882958ca831a26cd815635a563dd1bac9c93103fd6e9a2a4040b6ea3725395be96d0cbef9d7e01441402edf63a63110be41f5db559eb5fa85ac82a101751d SHA512 217348c3911995143e2d1f777ff6038ffd541f6868d58da9ca0a702610377f26eac7aafcd993d9b410b4d5a6d27d2c4fa8020b665beee7c2f760dc293a63c41f
-DIST f3-7.1.tar.gz 67934 BLAKE2B 7d5e12d8af7abda6136dfa19127554b6e5c45fdec7f0cef10d792d77cd2cfae035a572cdf2f22faf54c61852b1660e70270a326bb4408ed64725114f1f9aff4f SHA512 d696bb96ebaefab13c50a4479be01c206365d8dcf7d3c3b1d906b68705b654fffabdbeee49ea208047383c117bcac2a85c2c5fb129cace82f8addc16f22d7514
DIST f3-7.2.tar.gz 68471 BLAKE2B fa2e98ee0bdbad117c44bcc866d8ee5ef1572469d0b3cc48734de0fdb47653946774cc85429157f00d2a977662f593885074822bf1e069aa84ceafafa64726bf SHA512 4e41fca8b02dbd6bfaae01237a47573916aefe47f5aafc864618d708568e32ec122390c03af24d89caaf03de692fa374e87747b07a8546eaf8cafd57887a61ac
diff --git a/sys-block/f3/f3-7.0.ebuild b/sys-block/f3/f3-7.0.ebuild
deleted file mode 100644
index 987ef57f6f6d..000000000000
--- a/sys-block/f3/f3-7.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Utilities to detect broken or counterfeit flash storage"
-HOMEPAGE="http://oss.digirati.com.br/f3/ https://github.com/AltraMayor/f3"
-
-PATCHES=(
-)
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/AltraMayor/${PN}.git"
-
- PATCHES=()
-
- inherit git-r3
-else
- SRC_URI="https://github.com/AltraMayor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-IUSE="extra"
-
-DEPEND="extra? (
- sys-block/parted
- virtual/udev
- )"
-
-RDEPEND=""
-
-DOCS=( changelog README.rst )
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:-ggdb::' \
- -e 's:^PREFIX =:PREFIX ?=:' \
- Makefile || die
-
- tc-export CC
-
- append-cflags -fgnu89-inline # https://github.com/AltraMayor/f3/issues/34
-}
-
-src_compile() {
- default
-
- if use extra; then
- emake V=1 extra
- fi
-}
-
-src_install() {
- emake PREFIX="${ED%/}/usr" install
-
- if use extra; then
- emake PREFIX="${ED%/}/usr" install-extra
- fi
-
- dodoc "${DOCS[@]}"
-}
diff --git a/sys-block/f3/f3-7.1.ebuild b/sys-block/f3/f3-7.1.ebuild
deleted file mode 100644
index 726e10fa800d..000000000000
--- a/sys-block/f3/f3-7.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Utilities to detect broken or counterfeit flash storage"
-HOMEPAGE="http://oss.digirati.com.br/f3/ https://github.com/AltraMayor/f3"
-
-PATCHES=(
-)
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/AltraMayor/${PN}.git"
-
- PATCHES=()
-
- inherit git-r3
-else
- SRC_URI="https://github.com/AltraMayor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-IUSE="extra"
-
-DEPEND="extra? (
- sys-block/parted
- virtual/udev
- )"
-
-RDEPEND=""
-
-DOCS=( changelog README.rst )
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:-ggdb::' \
- -e 's:^PREFIX =:PREFIX ?=:' \
- Makefile || die
-
- tc-export CC
-}
-
-src_compile() {
- default
-
- if use extra; then
- emake V=1 extra
- fi
-}
-
-src_install() {
- emake PREFIX="${ED%/}/usr" install
-
- if use extra; then
- emake PREFIX="${ED%/}/usr" install-extra
- fi
-
- einstalldocs
-}