summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/relational/Manifest1
-rw-r--r--sci-mathematics/relational/relational-2.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-mathematics/relational/Manifest b/sci-mathematics/relational/Manifest
index ff01402214bc..30246943cdfb 100644
--- a/sci-mathematics/relational/Manifest
+++ b/sci-mathematics/relational/Manifest
@@ -1 +1,2 @@
DIST relational_2.4.orig.tar.gz 113606 SHA256 6e322ae4face623e91fb775171eb3758bcb9a253f2967c9e303208e9f32e5dee SHA512 c7cb6bf5c97df57e84f746d0adccbc3285ea863d692c2b999600ec70f8512e1a3f28a4414d2d34fa956ec6d7955ff290f638d048ada6b685d031823b46d368ff WHIRLPOOL 069c0f69237060fe1741c233678400abce7148ef865c6fa61847cc9395289f6f27b2b6456f632ded421ea3e9c0f4f3f8bb8d13713f72e950ad3608d7c4478052
+DIST relational_2.5.orig.tar.gz 118776 SHA256 511330beda30b7acea6a1122bbdf39b1ee8b8f026e41d2bab8aed8b8d52f89b7 SHA512 588e35a57cf915e544d62749b76ed81927ac06fd88271f0d4d88ee5f221928c2c24e2a88165aae63c1b9b120ddaa20e15e21fe9c207eac3150b744274ae45a8a WHIRLPOOL 1fd04109e1ed9ca89fa6c8464f7de71677d8642d9dd1060beca142f276a7df2d7f6a8a9baa620c0e19308b76bd2ff1cb683139adad3a0850856be3e64e7c0ca2
diff --git a/sci-mathematics/relational/relational-2.5.ebuild b/sci-mathematics/relational/relational-2.5.ebuild
new file mode 100644
index 000000000000..030001853625
--- /dev/null
+++ b/sci-mathematics/relational/relational-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit python-single-r1
+
+DESCRIPTION="Educational tool for relational algebra"
+HOMEPAGE="http://ltworf.github.io/relational/"
+SRC_URI="https://github.com/ltworf/${PN}/releases/download/${PV}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/PyQt5[gui,webkit,widgets,${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ sed -i -e '/^Terminal=/ s/0/false/' \
+ -e '/^Keywords=/ s/$/;/' \
+ relational.desktop || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" install-{relational-cli,python3-relational,relational}
+ python_optimize
+
+ dodoc CHANGELOG complexity CREDITS README.md
+}