summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/hackport/Manifest1
-rw-r--r--app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch33
-rw-r--r--app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch79
-rw-r--r--app-portage/hackport/files/hackport-0.6.3-old-filepath.patch40
-rw-r--r--app-portage/hackport/hackport-0.6.3.ebuild63
5 files changed, 216 insertions, 0 deletions
diff --git a/app-portage/hackport/Manifest b/app-portage/hackport/Manifest
index 718127ee5c8f..0bf4db42fd2a 100644
--- a/app-portage/hackport/Manifest
+++ b/app-portage/hackport/Manifest
@@ -1,2 +1,3 @@
DIST hackport-0.5.6.tar.gz 1639896 BLAKE2B 2c5892b3206b4cbb10f8dcbce1d043446b7b804ae0b5d1e59c49c733c80194e79c9091cfc933cbc7e7a592c0747ee034d56969d4261ad0a6a585259d5e8b4f76 SHA512 5dc20f11392757224a6cf79d525792e14aba64ffb44c9dd9b4f0df4acd9c00127d85f2b1f23cf2063f80895dbcc90ccc745e8f9aba3ef82f7ae8364db155fe4f
DIST hackport-0.6.2.tar.gz 1625948 BLAKE2B 9dbb7695d3ca806cfef342697717fa232be2156bcb76c87413907460a9cea2f8cdd517dce453ae7846a00df53ab46058c8f42bd36bc33580cb32452b82c77816 SHA512 99207c4903ee5f3fdcc648edcc3a39ed06f0629a1d5bda577fc2c443c544bfd746154bc5e9de044810c148b1a38028ec0fdf908513b4252c05bb6c9c6eb9aa92
+DIST hackport-0.6.3.tar.gz 1986620 BLAKE2B 6878b3f378b1c5303047c4e6ea27edd587527bc0f303dae8947f0e2a066452b5c4cf3a13594499c3b367ff515114f43c2fa7dece935a704f0f6855fc23f14100 SHA512 ef2f2125c89352207f82e02668bfd84c9e38d5ed3f8643d19d4f270cf7440169c7e6d24513f90e7d616900a06a429e54cf01a42363ff463d536fa37700b7d1cc
diff --git a/app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch b/app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch
new file mode 100644
index 000000000000..21c848ab53c5
--- /dev/null
+++ b/app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch
@@ -0,0 +1,33 @@
+From 4264f8bc91dabce03ac858388358ff5f4c6db8df Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sat, 25 Jan 2020 23:52:58 +0000
+Subject: [PATCH 2/3] hackport.cabal: add missing ForeignFunctionInterface
+ extension
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+gcc-8.0 does not enable `ForeignFunctionInterface` by default.
+
+Reported-by: Toralf Förster
+Bug: https://bugs.gentoo.org/704778
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ hackport.cabal | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hackport.cabal b/hackport.cabal
+index 049933e00..70928fe6b 100644
+--- a/hackport.cabal
++++ b/hackport.cabal
+@@ -70,6 +70,7 @@ Executable hackport
+ DoAndIfThenElse,
+ EmptyDataDecls,
+ ExistentialQuantification,
++ ForeignFunctionInterface,
+ FlexibleContexts,
+ FlexibleInstances,
+ GADTs,
+--
+2.25.0
+
diff --git a/app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch b/app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch
new file mode 100644
index 000000000000..fa6c446cf38b
--- /dev/null
+++ b/app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch
@@ -0,0 +1,79 @@
+From 4cd81196f7a477327ce87971b376e785f362b9b7 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Fri, 24 Jan 2020 08:09:34 +0000
+Subject: [PATCH 1/3] hackport.cabal: add missing test depends
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ hackport.cabal | 21 ++++++++++++++++++++-
+ 1 file changed, 20 insertions(+), 1 deletion(-)
+
+diff --git a/hackport.cabal b/hackport.cabal
+index 94d345292..049933e00 100644
+--- a/hackport.cabal
++++ b/hackport.cabal
+@@ -76,6 +76,7 @@ Executable hackport
+ GeneralizedNewtypeDeriving,
+ KindSignatures,
+ MultiParamTypeClasses,
++ -- cabal
+ PatternGuards,
+ RankNTypes,
+ RecordWildCards,
+@@ -86,7 +87,6 @@ Executable hackport
+ ViewPatterns
+ other-extensions:
+ DeriveDataTypeable,
+- PatternGuards,
+ -- extensions due to bundled cabal-install
+ CPP,
+ ForeignFunctionInterface,
+@@ -151,9 +151,15 @@ Test-Suite test-resolve-category
+ pretty,
+ process,
+ split,
++ text,
+ time,
++ transformers,
+ unix,
+ xml
++ default-extensions:
++ -- cabal
++ PatternGuards,
++ DoAndIfThenElse
+
+ Test-Suite test-print-deps
+ ghc-options: -Wall
+@@ -174,9 +180,15 @@ Test-Suite test-print-deps
+ parsec,
+ pretty,
+ process,
++ text,
+ time,
++ transformers,
+ unix,
+ xml
++ default-extensions:
++ -- cabal
++ PatternGuards,
++ DoAndIfThenElse
+
+ Test-Suite test-normalize-deps
+ ghc-options: -Wall
+@@ -197,6 +209,13 @@ Test-Suite test-normalize-deps
+ parsec,
+ pretty,
+ process,
++ text,
+ time,
++ transformers,
+ unix,
+ xml
++
++ default-extensions:
++ -- cabal
++ PatternGuards,
++ DoAndIfThenElse
+--
+2.25.0
+
diff --git a/app-portage/hackport/files/hackport-0.6.3-old-filepath.patch b/app-portage/hackport/files/hackport-0.6.3-old-filepath.patch
new file mode 100644
index 000000000000..c660db766b26
--- /dev/null
+++ b/app-portage/hackport/files/hackport-0.6.3-old-filepath.patch
@@ -0,0 +1,40 @@
+From b4fe6e48679084ca28c1192612c60599ae81808c Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sat, 25 Jan 2020 23:53:39 +0000
+Subject: [PATCH 3/3] Merge.hs: avoid using isExtensionOf
+
+`isExtensionOf` is not available in gcc-8.0.
+
+Reported-by: Jeremy Stent
+Bug: https://bugs.gentoo.org/704778
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ Merge.hs | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Merge.hs b/Merge.hs
+index 645817345..522a3739d 100644
+--- a/Merge.hs
++++ b/Merge.hs
+@@ -39,7 +39,8 @@ import System.Directory ( getCurrentDirectory
+ , listDirectory
+ )
+ import System.Process (system)
+-import System.FilePath ((</>), isExtensionOf)
++import System.FilePath ((</>))
++import qualified System.FilePath as SF
+ import System.Exit
+
+ import qualified Cabal2Ebuild as C2E
+@@ -183,7 +184,7 @@ getPreviousPackageId pkgDir newPkgId = do
+ . L.sortOn (Portage.pkgVersion)
+ . filter (<newPkgId)
+ $ Portage.filePathToPackageId newPkgId
+- <$> filter (\fp -> ".ebuild" `isExtensionOf` fp) pkgDir
++ <$> filter (\fp -> SF.takeExtension fp == ".ebuild") pkgDir
+ case pkgIds of
+ x:_ -> Just x
+ _ -> Nothing
+--
+2.25.0
+
diff --git a/app-portage/hackport/hackport-0.6.3.ebuild b/app-portage/hackport/hackport-0.6.3.ebuild
new file mode 100644
index 000000000000..5a74aa2efb67
--- /dev/null
+++ b/app-portage/hackport/hackport-0.6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.3.9999
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="http://hackage.haskell.org/package/hackport"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests are broken: need path to ebuild tree
+
+RDEPEND="
+ app-portage/repoman
+ dev-haskell/async:=
+ dev-haskell/base16-bytestring:=
+ dev-haskell/base64-bytestring:=
+ dev-haskell/cryptohash:=
+ dev-haskell/ed25519:=
+ dev-haskell/extensible-exceptions:=
+ dev-haskell/hashable:=
+ >=dev-haskell/http-4000.0.3:=
+ dev-haskell/missingh:=
+ dev-haskell/mtl:=
+ >=dev-haskell/network-2.6:=
+ >=dev-haskell/network-uri-2.6:=
+ dev-haskell/old-locale:=
+ dev-haskell/old-time:=
+ dev-haskell/parsec:=
+ dev-haskell/random:=
+ dev-haskell/regex-compat:=
+ dev-haskell/split:=
+ dev-haskell/stm:=
+ >=dev-haskell/tar-0.5:=
+ dev-haskell/text:=
+ >=dev-haskell/xml-1.3.7:=
+ dev-haskell/zlib:=
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-ffi.patch
+ "${FILESDIR}"/${P}-missing-test-deps.patch
+ "${FILESDIR}"/${P}-old-filepath.patch
+)
+
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+}