summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.7_p5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index ae868b67bc85..93f197def769 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -9,3 +9,4 @@ DIST pf-sources-5.7_p1.patch 131429 BLAKE2B 4a3c457631c25aebb217fccb287153ae2a67
DIST pf-sources-5.7_p2.patch 191823 BLAKE2B cdf2d7f1addda7380761843c1a75e44d5e911039036625fedea74a9ac965d206023b1450c80c46940dd2c5cd7057c031d589b4705c391c9b9a3eba2ba9f41305 SHA512 0152059e98c354a315b74575840f2c1badb5b8906090ed4818bb2638cff1981d8c4b15857ef3c39cda91faabcaafc96c89e4cb011ff7eb92e614afc66a7d50a1
DIST pf-sources-5.7_p3.patch 1536696 BLAKE2B ced07f59a174bb2c0579bd337a4036fdb09d8dac4f6a06bbb9392f83d4b0462d75678bd6ee01539c5bfaf99e866b09e33509c493036c151cc2b628ea6c22883c SHA512 31c644fbc1b27155754a5af217bb35358fc5e3ee485a442cc6a16aae87034608554236bcbf4c7fb1809a14283404a2881342044e4dfe2e1822a24245e026f97e
DIST pf-sources-5.7_p4.patch 1980479 BLAKE2B c3bde9ae7467ff626f7369a68d6d8f0ab30042c4d85e33e9dfdaca058e6bd9ba686eb9c61323cb2e9278f8ce2f4517d0f5304097b68296d6e96f87c97395ddd2 SHA512 9b8b02def4c3483b74538808e624b58cd5af131fde18b0a81b73c565aa258402b68619fa14ae073b6f0e625a923f6f64985982cb4368a44fe5dfe83fbb1170e3
+DIST pf-sources-5.7_p5.patch 2473444 BLAKE2B cea4b7f888e2ec76dde07310ab80bacfdc37f4237d26aa62ffd0f052ab7b432cf5be254c3c1311e610ca67ddd90b885723707b5af8381466736a67cd0051c103 SHA512 a10c3b1881c4783f02b412bd82e7aeb4bf9d8b3f323161b436585e97aa9a5b75abb39dda90c95833bb841193dc93ca40524bfe91f976d3e4e474f6a875511a97
diff --git a/sys-kernel/pf-sources/pf-sources-5.7_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.7_p5.ebuild
new file mode 100644
index 000000000000..2a683a5287d4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.7_p5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}