summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.30.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 03a0d822fc40..fcd6f19f5f2f 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.30.2.tar.xz 4528100 BLAKE2B 3b711df8aa3166c26f639658de188e730f346be7c9bdfc65a5064804c1b0e22a744aec6c559c4131125e8fb34e7bb80636f559c7257cca3ad044c6b810bbe657 SHA512 4edaa042357ad44f2069412508cff9524e6e397da868b78768b493d03d77d16807d78f074eb1a4b18fcc1143d3a63d21f3eb1c0f126a31290320016c76c5130e
DIST epiphany-3.30.3.tar.xz 4531796 BLAKE2B 83ef6fb907d14e7a6605a4bb5ec5ecb5d463e2f21efe87550af4e5972bb02b6e52ca8df1d9866954d86858faa727bcd3fd525145d99eeca2c1c63d5387953b61 SHA512 a94a15cca6632157ab636a240af0567dc0e6b1070b510c1befc29e5bec51ab80a89ff101aff9c985632791dbfe0378417cbc2df4d48c1b2ada90d3d5c22a80ab
+DIST epiphany-3.30.4.tar.xz 4531732 BLAKE2B a4741d353800517c0233456e513a974ecd7641799395df7cafe6940cbfa49402836484010634ef3c59e36bd3bb2ced331d19a4ed05d1630c00d7ee385961227b SHA512 8574a26a22a24db7e65254f65723f6e4405fccd783bb7e122f8a5f6aff62d3ef1dd0b3ce903eb1f750e7ae28c2f1154a2c1c15970892216211d51edee318bd47
diff --git a/www-client/epiphany/epiphany-3.30.4.ebuild b/www-client/epiphany/epiphany-3.30.4.ebuild
new file mode 100644
index 000000000000..ecb6ccc371db
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.30.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.52.0:2
+ >=x11-libs/gtk+-3.22.13:3
+ >=dev-libs/nettle-3.2:=
+ >=net-libs/webkit-gtk-2.21.92:4=
+ >=x11-libs/cairo-1.2
+ >=dev-libs/libdazzle-3.28.0
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ dev-libs/icu:=
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.14
+ >=net-libs/libsoup-2.48:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ dev-db/sqlite:3
+ dev-libs/gmp:0=
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# paxctl needed for bug #407085
+# appstream-glib needed for appdata.xml gettext translation
+DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-apps/paxctl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Ddistributor_name=Gentoo
+ -Dtech_preview=false
+ $(meson_use test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}