summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.15-r1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index a2080e607fd5..e0da14a55403 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,2 +1 @@
-DIST libxmlb-0.1.15.tar.gz 92923 BLAKE2B 97b6af812397dd279e7e3c038627fcf8228cbfa5c3af91ceeb5361e32d37d357eda6a193f627a5f4442426fb08abca1ff11684fe199d9d3a4add72ca4f3f5d08 SHA512 58268b3a690af36c0923afdee3ae58e88bf778eebbc6a439be1bc85ed985efdc20cd7006c976586f7be87310dc091d67dddd370f4bbec58379fc4e7349bfa3d8
DIST libxmlb-0.3.9.tar.gz 121878 BLAKE2B 4c61482f05535b84efb1bf466db8d89f58dddde9cb9d87eb22fe04343f89dc4efc882ff3d9f73131e8fc8c8c107a72fcc2765e5c1b3e290c52593666b7073b9d SHA512 ff2b6567d97801b58ddb87be71246065c2b9d666494059c2f7cc2535508d4754969f8411bd3a28a49664be2c21aeb95c75b999a06ee8448bf1fd962dd36ac47b
diff --git a/dev-libs/libxmlb/libxmlb-0.1.15-r1.ebuild b/dev-libs/libxmlb/libxmlb-0.1.15-r1.ebuild
deleted file mode 100644
index 36625e4a84a0..000000000000
--- a/dev-libs/libxmlb/libxmlb-0.1.15-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit meson python-any-r1
-
-DESCRIPTION="Library to help create and query binary XML blobs"
-HOMEPAGE="https://github.com/hughsie/libxmlb"
-SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-2.1+"
-SLOT="0"
-
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc introspection stemmer test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/glib:2
- sys-apps/util-linux
- stemmer? ( dev-libs/snowball-stemmer:= )
-"
-
-DEPEND="
- ${RDEPEND}
- doc? ( dev-util/gtk-doc )
- introspection? ( dev-libs/gobject-introspection )
-"
-
-BDEPEND="
- ${PYTHON_DEPS}
- >=dev-util/meson-0.47.0
- virtual/pkgconfig
- introspection? (
- $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
- )
-"
-
-python_check_deps() {
- has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local emesonargs=(
- -Dgtkdoc="$(usex doc true false)"
- -Dintrospection="$(usex introspection true false)"
- -Dstemmer="$(usex stemmer true false)"
- -Dtests="$(usex test true false)"
- )
- meson_src_configure
-}