summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-engines/odamex/Manifest1
-rw-r--r--games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch89
-rw-r--r--games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch110
-rw-r--r--games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch67
-rw-r--r--games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch58
-rw-r--r--games-engines/odamex/files/odamex-0.7.0-gcc6.patch39
-rw-r--r--games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch35
-rw-r--r--games-engines/odamex/files/odamex-0.7.0-miniupnpc20.patch28
-rw-r--r--games-engines/odamex/odamex-0.7.0-r1.ebuild109
9 files changed, 0 insertions, 536 deletions
diff --git a/games-engines/odamex/Manifest b/games-engines/odamex/Manifest
index 722a82bbe725..26a10f206ce9 100644
--- a/games-engines/odamex/Manifest
+++ b/games-engines/odamex/Manifest
@@ -1,2 +1 @@
-DIST odamex-src-0.7.0.tar.bz2 8435860 BLAKE2B 9720efdf262047074fed593360b0c38864d5d0f9c076a45d6df9aaf362cba35f41eeafab968338be0911681726872c33e3625934176f75068ca4933655876f7b SHA512 410f3c2588e4d57006e5bb50eaa0f6c1a83cf197ce40daabb958667483eb6c85138206ac74b8aee64c4208c4360415ad16d1698534be5c7abec1493a0f91aa8b
DIST odamex-src-0.8.1.tar.bz2 8520197 BLAKE2B 9744460f2a2bff375cbf80416a38212e7576a4ef6874d2647c1371dc66b464666d67dd69ac61c918c51bee6da0150cbb70799eb81fc2fd7ff62edaec332241a5 SHA512 5cdd05df9683c9b26cac5e2947f5365405b0c6239890d89ab962f4ac088788148bb1eabc15e80b0f13fca0dea69bffcd9e80e8aa80c6ac0a5d7e63b0bd983642
diff --git a/games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch b/games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch
deleted file mode 100644
index 618f9fd87c2c..000000000000
--- a/games-engines/odamex/files/1-odamex-0.7.0-install-rules.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 1352b633388dd9d82b8cb7e3d11932d0b569da4e Mon Sep 17 00:00:00 2001
-From: hasufell <hasufell@gentoo.org>
-Date: Thu, 27 Mar 2014 21:07:37 +0100
-Subject: [PATCH 1/4] make install destinations modifiable
-
----
- CMakeLists.txt | 5 +++--
- client/CMakeLists.txt | 2 +-
- master/CMakeLists.txt | 4 ++++
- odalaunch/CMakeLists.txt | 2 +-
- server/CMakeLists.txt | 2 +-
- 5 files changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 11e52d1..262e3db 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,4 +1,5 @@
- include(CMakeDependentOption)
-+include(GNUInstallDirs)
-
- project(Odamex)
- cmake_minimum_required(VERSION 2.8)
-@@ -113,10 +114,10 @@ if(NOT APPLE)
- set(CPACK_INCLUDE_TOPLEVEL_DIRECTORY OFF)
- else()
- install(FILES odamex.wad LICENSE README
-- DESTINATION share/odamex
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex
- COMPONENT common)
- install(FILES ${CONFIG_SAMPLES}
-- DESTINATION share/odamex/config-samples
-+ DESTINATION ${CMAKE_INSTALL_DATADIR}/odamex/config-samples
- COMPONENT common)
-
- option(ODAMEX_COMPONENT_PACKAGES "Create several rpm/deb packages for repository maintainers." OFF)
-diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
-index 510b820..3f73ab5 100644
---- a/client/CMakeLists.txt
-+++ b/client/CMakeLists.txt
-@@ -228,7 +228,7 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
- COMPONENT client)
- else()
- install(TARGETS odamex
-- RUNTIME DESTINATION bin
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- COMPONENT client)
- endif()
- endif()
-diff --git a/master/CMakeLists.txt b/master/CMakeLists.txt
-index 7fc386b..5bdc048 100644
---- a/master/CMakeLists.txt
-+++ b/master/CMakeLists.txt
-@@ -14,3 +14,7 @@ if(WIN32)
- elseif(SOLARIS)
- target_link_libraries(odamast socket nsl)
- endif()
-+
-+if(UNIX)
-+ install( TARGETS odamast DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
-diff --git a/odalaunch/CMakeLists.txt b/odalaunch/CMakeLists.txt
-index 4ca5920..0b134ef 100644
---- a/odalaunch/CMakeLists.txt
-+++ b/odalaunch/CMakeLists.txt
-@@ -71,7 +71,7 @@ if(wxWidgets_FOUND)
- COMPONENT odalaunch)
- else()
- install(TARGETS odalaunch
-- RUNTIME DESTINATION bin
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- COMPONENT odalaunch)
- endif()
-
-diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
-index b046714..d33b974 100644
---- a/server/CMakeLists.txt
-+++ b/server/CMakeLists.txt
-@@ -73,6 +73,6 @@ elseif(WIN32)
- COMPONENT server)
- else()
- install(TARGETS odasrv
-- RUNTIME DESTINATION bin
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- COMPONENT server)
- endif()
---
-1.9.1
-
diff --git a/games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch b/games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch
deleted file mode 100644
index 1de502711406..000000000000
--- a/games-engines/odamex/files/2-odamex-0.7.0-cmake-options.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-From 851bc58a74eadd89838c924167f27df1b9d3be37 Mon Sep 17 00:00:00 2001
-From: hasufell <hasufell@gentoo.org>
-Date: Thu, 27 Mar 2014 21:14:20 +0100
-Subject: [PATCH 2/4] add various cmake options
-
----
- CMakeLists.txt | 26 ++++++++++++++++++++++----
- client/CMakeLists.txt | 34 ++++++++++++++++++++--------------
- 2 files changed, 42 insertions(+), 18 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 262e3db..91d5c50 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,6 +1,13 @@
- include(CMakeDependentOption)
- include(GNUInstallDirs)
-
-+# options
-+option(BUILD_CLIENT "Build client target" 1)
-+option(BUILD_SERVER "Build server target" 1)
-+option(BUILD_MASTER "Build master server target" 1)
-+cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
-+cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
-+
- project(Odamex)
- cmake_minimum_required(VERSION 2.8)
-
-@@ -73,10 +80,21 @@ if(USE_INTREE_PORTMIDI)
- endif()
-
- # Subdirectories for Odamex projects
--add_subdirectory(client)
--add_subdirectory(server)
--add_subdirectory(master)
--add_subdirectory(odalaunch)
-+if(BUILD_CLIENT)
-+ add_subdirectory(client)
-+endif()
-+if(BUILD_SERVER)
-+ add_subdirectory(server)
-+endif()
-+if(BUILD_MASTER)
-+ add_subdirectory(master)
-+endif()
-+if(BUILD_ODALAUNCH)
-+ add_subdirectory(odalaunch)
-+endif()
-+if(NOT BUILD_CLIENT AND NOT BUILD_SERVER AND NOT BUILD_MASTER)
-+ message(FATAL_ERROR "No target chosen, doing nothing.")
-+endif()
-
- # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
- # This is only really useful when setting up a universal build.
-diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
-index 3f73ab5..7363c5a 100644
---- a/client/CMakeLists.txt
-+++ b/client/CMakeLists.txt
-@@ -107,17 +107,21 @@ include_directories(${PNG_INCLUDE_DIRS})
- add_definitions(-DUSE_PNG)
-
- # PortMidi configuration
--if(USE_INTREE_PORTMIDI)
-- include_directories(../libraries/portmidi/pm_common/ ../libraries/portmidi/porttime/)
-- add_definitions(-DPORTMIDI)
-+if(ENABLE_PORTMIDI)
-+ if(USE_INTREE_PORTMIDI)
-+ include_directories(../libraries/portmidi/pm_common/ ../libraries/portmidi/porttime/)
-+ add_definitions(-DPORTMIDI)
-+ else()
-+ find_package(PortMidi QUIET)
-+ if(PORTMIDI_FOUND)
-+ include_directories(${PORTMIDI_INCLUDE_DIR})
-+ add_definitions(-DPORTMIDI)
-+ else()
-+ message(WARNING "PortMidi not found, client will be built without PortMidi support.")
-+ endif()
-+ endif()
- else()
-- find_package(PortMidi QUIET)
-- if(PORTMIDI_FOUND)
-- include_directories(${PORTMIDI_INCLUDE_DIR})
-- add_definitions(-DPORTMIDI)
-- else()
-- message(WARNING "PortMidi not found, client will be built without PortMidi support.")
-- endif()
-+ message(STATUS "Portmidi disabled.")
- endif()
-
- # Find Mac frameworks
-@@ -147,10 +151,12 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
- target_link_libraries(odamex ${ZLIB_LIBRARY})
- target_link_libraries(odamex ${PNG_LIBRARY} ${ZLIB_LIBRARY})
-
-- if(USE_INTREE_PORTMIDI)
-- target_link_libraries(odamex portmidi-static)
-- elseif(PORTMIDI_FOUND)
-- target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
-+ if(ENABLE_PORTMIDI)
-+ if(USE_INTREE_PORTMIDI)
-+ target_link_libraries(odamex portmidi-static)
-+ elseif(PORTMIDI_FOUND)
-+ target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
-+ endif()
- endif()
-
- if(WIN32)
---
-1.9.1
-
diff --git a/games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch b/games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch
deleted file mode 100644
index 77fb4e48996e..000000000000
--- a/games-engines/odamex/files/3-odamex-0.7.0-wad-search-path.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 9af4e992ff9fa10816beba36478c711ac2c8542a Mon Sep 17 00:00:00 2001
-From: hasufell <hasufell@gentoo.org>
-Date: Thu, 27 Mar 2014 21:17:21 +0100
-Subject: [PATCH 3/4] add odamex.wad install destination to wad search path
-
----
- CMakeLists.txt | 9 +++++++++
- common/d_main.cpp | 2 ++
- config.h.in | 6 ++++++
- 3 files changed, 17 insertions(+)
- create mode 100644 config.h.in
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 91d5c50..a06613e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -13,6 +13,15 @@
-
- set(PROJECT_VERSION 0.7.0)
- set(PROJECT_COPYRIGHT "2006-2014")
-+
-+configure_file (
-+ "${PROJECT_SOURCE_DIR}/config.h.in"
-+ "${PROJECT_BINARY_DIR}/config.h"
-+ )
-+
-+include_directories(
-+ ${PROJECT_BINARY_DIR}
-+)
-
- # Default build type
- if(NOT MSVC)
-diff --git a/common/d_main.cpp b/common/d_main.cpp
-index 31d4f59..be0ffd2 100644
---- a/common/d_main.cpp
-+++ b/common/d_main.cpp
-@@ -23,6 +23,7 @@
- //-----------------------------------------------------------------------------
-
- #include "version.h"
-+#include "config.h"
-
- #include <sstream>
- #include <string>
-@@ -506,6 +507,7 @@ static std::string BaseFileSearch(std::string file, std::string ext = "", std::s
- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
- D_AddSearchDir(dirs, getenv("HOME"), separator);
-+ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
-
- // [AM] Search additional paths based on platform
- D_AddPlatformSearchDirs(dirs);
-diff --git a/config.h.in b/config.h.in
-new file mode 100644
-index 0000000..e91b3a6
---- /dev/null
-+++ b/config.h.in
-@@ -0,0 +1,6 @@
-+#ifndef CONFIG_H
-+#define CONFIG_H
-+
-+#define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
-+
-+#endif
---
-1.9.1
-
diff --git a/games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch b/games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch
deleted file mode 100644
index acb2692e75fb..000000000000
--- a/games-engines/odamex/files/4-odamex-0.7.0-odalauncher-bin-path.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 672b2e61f3c0347c29746a4a22fe3ab912e88d62 Mon Sep 17 00:00:00 2001
-From: hasufell <hasufell@gentoo.org>
-Date: Thu, 27 Mar 2014 21:19:48 +0100
-Subject: [PATCH 4/4] use CMAKE_BINDIR as default bin patch in odalauncher
-
----
- config.h.in | 1 +
- odalaunch/src/dlg_main.cpp | 6 +++++-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/config.h.in b/config.h.in
-index e91b3a6..7019a02 100644
---- a/config.h.in
-+++ b/config.h.in
-@@ -2,5 +2,6 @@
- #define CONFIG_H
-
- #define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
-+#define CMAKE_BINDIR "@CMAKE_INSTALL_BINDIR@"
-
- #endif
-diff --git a/odalaunch/src/dlg_main.cpp b/odalaunch/src/dlg_main.cpp
-index a95a5f6..abbfc0a 100644
---- a/odalaunch/src/dlg_main.cpp
-+++ b/odalaunch/src/dlg_main.cpp
-@@ -27,6 +27,7 @@
- #include "str_utils.h"
-
- #include "md5.h"
-+#include "config.h"
-
- #include <wx/settings.h>
- #include <wx/menu.h>
-@@ -42,6 +43,7 @@
- #include <wx/process.h>
- #include <wx/toolbar.h>
- #include <wx/xrc/xmlres.h>
-+#include <wx/string.h>
- #include <wx/cmdline.h>
-
- #ifdef __WXMSW__
-@@ -205,10 +207,12 @@ dlgMain::dlgMain(wxWindow* parent, wxWindowID id)
- }
- #endif
-
-+ const char *cmake_bindir_str = CMAKE_BINDIR;
-+ wxString cmake_bindir = wxString::FromAscii(cmake_bindir_str);
- launchercfg_s.get_list_on_start = 1;
- launchercfg_s.show_blocked_servers = 0;
- launchercfg_s.wad_paths = wxGetCwd();
-- launchercfg_s.odamex_directory = wxGetCwd();
-+ launchercfg_s.odamex_directory = cmake_bindir;
-
- m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
- m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
---
-1.9.1
-
diff --git a/games-engines/odamex/files/odamex-0.7.0-gcc6.patch b/games-engines/odamex/files/odamex-0.7.0-gcc6.patch
deleted file mode 100644
index 9e341b881ccd..000000000000
--- a/games-engines/odamex/files/odamex-0.7.0-gcc6.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Bug: https://bugs.gentoo.org/610566
-Commit: https://github.com/odamex/odamex/commit/1d8121c78fe2db9befb05dd40ceb9b86062024e4
-
-From 1d8121c78fe2db9befb05dd40ceb9b86062024e4 Mon Sep 17 00:00:00 2001
-From: rice <russell@odamex.net>
-Date: Tue, 30 Aug 2016 08:37:15 +0000
-Subject: [PATCH] - Apply patch from bug 1177, thanks RjY!
-
-SVN r5444 (trunk)
----
- common/m_vectors.cpp | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/common/m_vectors.cpp b/common/m_vectors.cpp
-index b51e4e40..2eb48a04 100644
---- a/common/m_vectors.cpp
-+++ b/common/m_vectors.cpp
-@@ -541,16 +541,16 @@ void M_PerpendicularVec3(v3double_t *dest, const v3double_t *src)
- {
- // find the smallest component of the vector src
- v3double_t tempvec;
-- double minelem = src->x;
-+ double minelem = fabs(src->x);
- double *mincomponent = &(tempvec.x);
-- if (abs(src->y) < minelem)
-+ if (fabs(src->y) < minelem)
- {
-- minelem = abs(src->y);
-+ minelem = fabs(src->y);
- mincomponent = &(tempvec.y);
- }
-- if (abs(src->z) < minelem)
-+ if (fabs(src->z) < minelem)
- {
-- minelem = abs(src->z);
-+ minelem = fabs(src->z);
- mincomponent = &(tempvec.z);
- }
-
diff --git a/games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch b/games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch
deleted file mode 100644
index 34896e2a4e8b..000000000000
--- a/games-engines/odamex/files/odamex-0.7.0-miniupnpc.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Thu Mar 27 21:16:02 UTC 2014
-Subject: unbundle miniupnpc
-
---- a/server/CMakeLists.txt
-+++ b/server/CMakeLists.txt
-@@ -29,8 +29,7 @@
- set(JSONCPP_SOURCE ${JSONCPP_DIR}/jsoncpp.cpp)
-
- # MiniUPnPc
--set(MINIUPNPC_DIR ../libraries/libminiupnpc)
--set(MINIUPNPC_STATIC_LIBRARIES upnpc-static)
-+set(MINIUPNPC_DIR /usr/include/miniupnpc)
-
- # Platform definitions
- define_platform()
-@@ -54,7 +53,7 @@
- ${COMMON_SOURCES} ${COMMON_HEADERS}
- ${SERVER_SOURCES} ${SERVER_HEADERS}
- ${SERVER_WIN32_HEADERS} ${SERVER_WIN32_RESOURCES})
--target_link_libraries(odasrv ${MINIUPNPC_STATIC_LIBRARIES})
-+target_link_libraries(odasrv -lminiupnpc)
-
- if(WIN32)
- target_link_libraries(odasrv winmm wsock32)
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -71,7 +71,6 @@
- set(UPNPC_BUILD_TESTS OFF CACHE INTERNAL "" FORCE)
- set(UPNPC_INSTALL OFF CACHE INTERNAL "" FORCE)
- mark_as_advanced(FORCE UPNPC_INSTALL)
--add_subdirectory(libraries/libminiupnpc)
-
- # PortMidi
- cmake_dependent_option(USE_INTREE_PORTMIDI "Compile with the version of PortMidi included in the source tree." ON "WIN32" OFF)
diff --git a/games-engines/odamex/files/odamex-0.7.0-miniupnpc20.patch b/games-engines/odamex/files/odamex-0.7.0-miniupnpc20.patch
deleted file mode 100644
index 377286220b11..000000000000
--- a/games-engines/odamex/files/odamex-0.7.0-miniupnpc20.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: common/i_net.cpp
-===================================================================
---- a/common/i_net.cpp (revision 5459)
-+++ b/common/i_net.cpp (working copy)
-@@ -151,7 +151,11 @@
-
- Printf(PRINT_HIGH, "UPnP: Discovering router (max 1 unit supported)\n");
-
-+#if MINIUPNPC_API_VERSION < 14
- devlist = upnpDiscover(sv_upnp_discovertimeout.asInt(), NULL, NULL, 0, 0, &res);
-+#else
-+ devlist = upnpDiscover(sv_upnp_discovertimeout.asInt(), NULL, NULL, 0, 0, 2, &res);
-+#endif
-
- if (!devlist || res != UPNPDISCOVER_SUCCESS)
- {
-@@ -179,7 +183,11 @@
- // " desc: %s\n st: %s\n",
- // dev->descURL, dev->st);
-
-+#if MINIUPNPC_API_VERSION < 16
- descXML = (char *)miniwget(dev->descURL, &descXMLsize, 0);
-+#else
-+ descXML = (char *)miniwget(dev->descURL, &descXMLsize, 0, &res);
-+#endif
-
- if (descXML)
- {
diff --git a/games-engines/odamex/odamex-0.7.0-r1.ebuild b/games-engines/odamex/odamex-0.7.0-r1.ebuild
deleted file mode 100644
index 78af4a724d7e..000000000000
--- a/games-engines/odamex/odamex-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER="3.0"
-inherit cmake-utils desktop gnome2-utils readme.gentoo-r1 wxwidgets
-
-MY_P=${PN}-src-${PV}
-DESCRIPTION="Online multiplayer, free software engine for Doom and Doom II"
-HOMEPAGE="https://odamex.net/"
-SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dedicated master +odalaunch portmidi server"
-
-RDEPEND="
- dedicated? ( >=net-libs/miniupnpc-1.8:0= )
- !dedicated? (
- media-libs/libpng:0=
- >=media-libs/libsdl-1.2.9[X,sound,joystick,video]
- >=media-libs/sdl-mixer-1.2.6
- odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- portmidi? ( media-libs/portmidi )
- server? ( >=net-libs/miniupnpc-1.8:0= )
- )
-"
-DEPEND="${RDEPEND}"
-
-DOC_CONTENTS="
- This is just the engine, you will need doom resource files in order to play.
- Check: http://odamex.net/wiki/FAQ#What_data_files_are_required.3F
-"
-
-S="${WORKDIR}/src-${PV:2:3}"
-
-PATCHES=(
- "${FILESDIR}"/1-${P}-install-rules.patch
- "${FILESDIR}"/2-${P}-cmake-options.patch
- "${FILESDIR}"/3-${P}-wad-search-path.patch
- "${FILESDIR}"/4-${P}-odalauncher-bin-path.patch
- "${FILESDIR}"/${P}-miniupnpc.patch
- "${FILESDIR}"/${P}-miniupnpc20.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_prepare() {
- cmake-utils_src_prepare
- rm -r libraries/libminiupnpc || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_INTREE_PORTMIDI=OFF
- -DCMAKE_INSTALL_BINDIR="/usr/bin"
- -DCMAKE_INSTALL_DATADIR="/usr/share"
- -DBUILD_MASTER=$(usex master)
- )
-
- if use dedicated ; then
- mycmakeargs+=(
- -DBUILD_CLIENT=OFF
- -DBUILD_ODALAUNCH=OFF
- -DENABLE_PORTMIDI=OFF
- -DBUILD_SERVER=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_CLIENT=ON
- -DBUILD_ODALAUNCH=$(usex odalaunch)
- -DENABLE_PORTMIDI=$(usex portmidi)
- -DBUILD_SERVER=$(usex server)
- )
- fi
-
- append-cxxflags -std=c++11
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- readme.gentoo_create_doc
-
- if ! use dedicated ; then
- newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
- make_desktop_entry ${PN}
-
- if use odalaunch ; then
- newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
- make_desktop_entry odalaunch "Odamex Launcher" odalaunch
- fi
- fi
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- readme.gentoo_print_elog
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}