summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/cadvisor/Manifest1
-rw-r--r--app-emulation/cadvisor/cadvisor-0.33.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/Manifest b/app-emulation/cadvisor/Manifest
index 55128c2ebc1a..a795318c17ef 100644
--- a/app-emulation/cadvisor/Manifest
+++ b/app-emulation/cadvisor/Manifest
@@ -1,2 +1,3 @@
DIST cadvisor-0.31.0.tar.gz 4604581 BLAKE2B b39cc3c2482353f1fb64ee0bb9baccdd310e6315819c21aaaef034970f39e2d6ffae05de4289b50838e8bad889f7d9a8e516768ba56a6854c76829a621e57554 SHA512 13b92c2148a439def2394232b3591c0367431f09f5998b5a79210e5b871e2986934fda8b1a3bbeb10691bb5b512556b76f32976b977005d767974c565bcf9072
DIST cadvisor-0.32.0.tar.gz 4623510 BLAKE2B 7145d0224b3d64cd438bb94047d8682bcad842d7841d98f264a3118a2c0fabb7f67b183db80e054362428efc4f47c699692e53e651a14a1871cc3c32d3a0695f SHA512 734ad1f33e0948dba7e43a1695c3a96ce6bf4367a604b5b79f011c893e18ec697c48199ddb21edb7c176929ddd389e42de9b6f502a01c938c45612ffd96b5f5d
+DIST cadvisor-0.33.0.tar.gz 4646920 BLAKE2B ce0e264321efcfbbf422f086cd15dfde389a099d183cbc2daaefb5aa6aa36da0c6e213dc4c12a000b9049ce2a1444addee93746f5650a56fa0f7c6612aa25bd9 SHA512 3d1dd1b9dc684e71bca9dc64949911f5f3ae72c97aa3b6cd45dd51a404fc101b5591ec8c19c469d6a410de3cf46c3d8c104d34e5dd1fdc85c18c2d1b6a45b2af
diff --git a/app-emulation/cadvisor/cadvisor-0.33.0.ebuild b/app-emulation/cadvisor/cadvisor-0.33.0.ebuild
new file mode 100644
index 000000000000..1c6593a306f2
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.33.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="511ec9e"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ sed -i -e "/go get/d" src/${EGO_PN}/build/assets.sh || die
+ sed -i -e "s/git describe.*/echo ${PV} )/"\
+ -e "s/git rev-parse --short HEAD.*/echo ${COMMIT} )/"\
+ src/${EGO_PN}/build/build.sh || die
+ default
+}
+
+src_compile() {
+ pushd "src/${EGO_PN}"
+ GO_FLAGS="-v -work -x" VERBOSE="true" GOPATH="${S}:$(get_golibdir_gopath)" emake build
+ popd || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dobin src/${EGO_PN}/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}