summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index defc80496373..007fd64e9e36 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,3 +1,2 @@
-DIST qbittorrent-4.1.2.tar.gz 7697135 BLAKE2B 13e9456fd43395d597156519bdd665db898d462761dc5fe5f92e40994e8d0e214b0a1f9d8d327d44f8deb287c646c7013c17099bca193d85d1a3b2d851ada976 SHA512 25293378693cec875d1b52ea5aca8087a0d31021e6fbb4bd31f05c6979e36a5dc03983f2007a067942e1e119878b94a9e2b9622f324c7592f6630dcfe008b757
DIST qbittorrent-4.1.3.tar.gz 7268632 BLAKE2B 72388d1198dd9bdf4844c1769c7a7c8fe2fcf8213bc0442dc1900ec4b0968a5aa291b0fb35e3e89b7fa7395cc336c44a447ae6d4360504393a68343e5f10efff SHA512 ffacd3755c8f4487d13c339ff40f6e52765fad2e68f6ea2892ea58c9e702f591fd6aafda48ec4fc8b5fecfa81fd34e3a1d5b96676f76ae657b3420d080323c09
DIST qbittorrent-4.1.4.tar.gz 7718217 BLAKE2B 46fc3ad230a74cc2f05bdfe5f53b6b39e0dcd99afff941614345ef1d85492f647080a6111c403f30746b24d1b03e1a6fd196015c7646dc5ab5c73027a8c8c5b8 SHA512 2621a9b6a19609bafd2d99336e5dc4c5f4aef9e5ab6ecebd9c622c759cdcea2a18999c08a70ac32d88fbd65c310749ea2254562152c1d3886285aa7c5c86bf68
diff --git a/net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild
deleted file mode 100644
index 07ff1267c5e7..000000000000
--- a/net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit desktop gnome2-utils xdg-utils
-
-DESCRIPTION="BitTorrent client in C++ and Qt"
-HOMEPAGE="https://www.qbittorrent.org
- https://github.com/qbittorrent"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
-else
- SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64 x86"
- S="${WORKDIR}/qBittorrent-release-${PV}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+dbus debug webui +X"
-REQUIRED_USE="dbus? ( X )"
-
-RDEPEND="
- >=dev-libs/boost-1.62.0-r1:=
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5[ssl]
- >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
- dev-qt/qtxml:5
- >=net-libs/libtorrent-rasterbar-1.0.6:0=
- sys-libs/zlib
- dbus? ( dev-qt/qtdbus:5 )
- X? (
- dev-libs/geoip
- dev-qt/qtgui:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- )"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig"
-
-DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
-
-src_configure() {
- econf --with-qtsingleapplication=system \
- $(use_enable dbus qt-dbus) \
- $(use_enable debug) \
- $(use_enable webui) \
- $(use_enable X gui)
-}
-
-src_install() {
- emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
- domenu dist/unix/qbittorrent.desktop
- einstalldocs
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}