summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/tetzle/Manifest1
-rw-r--r--games-board/tetzle/tetzle-2.1.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-board/tetzle/Manifest b/games-board/tetzle/Manifest
index 13f0b8cc7a07..30866c01c46a 100644
--- a/games-board/tetzle/Manifest
+++ b/games-board/tetzle/Manifest
@@ -1 +1,2 @@
DIST tetzle-2.0.3-src.tar.bz2 641065 BLAKE2B ff5108fa592c3907bcf38af3b2bf2984f80734bf6ae8fd8f78d52d657089db11acae6b7d6c5cc206c157b11b0fe1fc66a054f1dbf981b0de2edcdb61bed9bee8 SHA512 39853cc37b0bae676fc516e56c2bb6a54d5cacccd5978d5bd9cd735bf9fcb09948871af06cdb3b3d1a510c51ea71ac3720bbfe2558c2effaa00e00708a70f7d9
+DIST tetzle-2.1.1-src.tar.bz2 1246920 BLAKE2B dab8128b70fd6650da190b27f356b1db9d763b65b9192cb19140d81b5ae6aed8eadef19d5c5e36a9d223e5a9dee81c8c90b604a822df7dce725b4c98fbe139b0 SHA512 80022556ccadc19f0b4357b0f629b340cb040fdff927dccd540fba5383ae4638fcca020be020c78a3809d0ca70fae7d7f19342f3e2a162f53f5e5e3b83ddf11d
diff --git a/games-board/tetzle/tetzle-2.1.1.ebuild b/games-board/tetzle/tetzle-2.1.1.ebuild
new file mode 100644
index 000000000000..de1e76ffa68a
--- /dev/null
+++ b/games-board/tetzle/tetzle-2.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils
+
+DESCRIPTION="A jigsaw puzzle game that uses tetrominoes for the pieces"
+HOMEPAGE="https://gottcode.org/tetzle/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+DOCS=( ChangeLog CREDITS )
+
+src_configure() {
+ eqmake5
+}
+
+src_install(){
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}