summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/rust-bin/rust-bin-1.70.0-r1.ebuild (renamed from dev-lang/rust-bin/rust-bin-1.70.0.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.70.0.ebuild b/dev-lang/rust-bin/rust-bin-1.70.0-r1.ebuild
index 93ef429779a2..5205a10f872a 100644
--- a/dev-lang/rust-bin/rust-bin-1.70.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.70.0-r1.ebuild
@@ -39,10 +39,6 @@ BDEPEND="
REQUIRED_USE="x86? ( cpu_flags_x86_sse2 )"
-# stripping rust may break it (at least on x86_64)
-# https://github.com/rust-lang/rust/issues/112286
-RESTRICT="strip"
-
QA_PREBUILT="
opt/${P}/bin/.*
opt/${P}/lib/.*.so
@@ -208,6 +204,11 @@ multilib_src_install() {
# BUG: installs x86_64 binary on other arches
rm -f "${ED}/opt/${P}/lib/rustlib/"*/bin/rust-llvm-dwp || die
+
+ # libLLVM must NOT be stripped
+ # it's not present on all arches, but if present and stripped rustc will segfault.
+ # https://github.com/rust-lang/rust/issues/112286
+ dostrip -x *libLLVM-*
}
pkg_postinst() {