summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/playerctl/Manifest1
-rw-r--r--media-sound/playerctl/metadata.xml12
-rw-r--r--media-sound/playerctl/playerctl-0.5.0.ebuild51
3 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/playerctl/Manifest b/media-sound/playerctl/Manifest
new file mode 100644
index 000000000000..83cf4d4c9002
--- /dev/null
+++ b/media-sound/playerctl/Manifest
@@ -0,0 +1 @@
+DIST playerctl-0.5.0.tar.gz 17015 SHA256 e1ea761c05774471a0a1274ad93805178b32d55d358ece0424fd087c1def8017 SHA512 307cad5eeea7efa0c97c885660f49468f442fe907ef2495b56ac512e0551c7248750897b6d00934cbfcfcb35f486a101a238b276ef71d2ef866132ca3cc0932c WHIRLPOOL 11e374a1b38586a8ee362b821d503af8175c36f0b48f067c91176d32aeae034a4fbd6c1e2afc2c78987a7be574248f0c8f329efc2dcf4b07f8df52d8e7d35726
diff --git a/media-sound/playerctl/metadata.xml b/media-sound/playerctl/metadata.xml
new file mode 100644
index 000000000000..1621dbd7fa0b
--- /dev/null
+++ b/media-sound/playerctl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <longdescription>
+ mpris command-line controller and library for spotify, vlc,
+ audacious, bmp, xmms2, and others.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/playerctl/playerctl-0.5.0.ebuild b/media-sound/playerctl/playerctl-0.5.0.ebuild
new file mode 100644
index 000000000000..7f5b861c3997
--- /dev/null
+++ b/media-sound/playerctl/playerctl-0.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc introspection"
+
+RDEPEND="
+ dev-libs/glib:2
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if ! use doc; then
+ echo 'EXTRA_DIST = ' > gtk-doc.make || die
+ fi
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc gtk-doc-html) \
+ $(use_enable introspection)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}